Daemon Power

The NetBSD Packages Collection: sysutils/liboobs

Brief description of the package:
Lightweight GObject based interface to system-tools-backends

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://www.gnome.org/.

Please note that this package has a gnu-gpl-v2 license.

The package is located in the "sysutils/liboobs" directory. The current source version of the package is "liboobs-2.22.2nb11". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for sysutils/liboobs :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: hal>=0.5.11 pciids-[0-9]* cwrappers>=20150314 libvolume_id>=0.81.0 glib2>=2.4.0 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.0.11 meson-[0-9]* ninja-build-[0-9]* python37>=3.7 libuuid>=2.18 readline>=2.2 readline>=6.0 python37>=3.7.0 re2c>=0.11.3 py37-setuptools>=0.8 py37-expat-[0-9]* python37>=3.7.5 usbids>=20081118 policykit>=0.9 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 dbus>=0.91 xmlto-[0-9]* getopt-[0-9]* docbook-xsl>=1.67.0nb1 docbook-xml>=4.2 perl>=5.0 libxslt>=1.1.8 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 libgcrypt>=1.6.0 libxml2>=2.8.0nb2 docbook-xml-[0-9]* docbook-xsl-[0-9]* libxslt>=1.1.28nb2 x11-links>=1.30 osabi-NetBSD-8.0_STABLE dbus-glib>=0.61 glib2>=2.40 dbus>=1.8 glib2>=2.34.0 dbus-glib>=0.100nb1 libxslt-[0-9]* hal-info>=20081022 policykit>=0.9nb12 system-tools-backends>=2.6.0 p5-XML-Twig>=3.32 p5-XML-Parser>=2.23 perl>=5.30.0 perl<5.32.0 p5-Net-DBus>=0.33.6 p5-XML-Twig-[0-9]* dbus>=1.0.0 p5-libwww>=5.820 p5-Encode-Locale>=0 p5-File-Listing>=6 p5-HTTP-Date>=6.00 p5-HTTP-Cookies>=6 p5-HTTP-Message>=6.02 p5-URI-[0-9]* p5-Test-Needs-[0-9]* p5-HTML-Parser>=3.33 p5-HTML-Tagset>=3.0 p5-HTTP-Date>=6 p5-Encode-Locale>=1.02 p5-LWP-MediaTypes>=6.01 p5-IO-HTML-[0-9]* p5-Try-Tiny-[0-9]* p5-Capture-Tiny>=0.12 p5-HTTP-Daemon>=6 p5-HTTP-Negotiate>=6 p5-HTTP-Message>=6 p5-LWP-MediaTypes>=6 p5-Net-HTTP>=6.18 p5-URI>=1.10 p5-WWW-RobotRules>=6.01 p5-URI>=1.27 p5-LWP-Protocol-https>=6.02 p5-IO-Socket-SSL>=1.38 p5-IO-Socket-INET6-[0-9]* p5-Socket6>=0.12 p5-Net-LibIDN-[0-9]* libidn>=0.4.6 libidn>=1.20nb1 p5-Net-SSLeay>=1.59 p5-Mozilla-CA-[0-9]* p5-Mozilla-CA>=20110101 p5-Crypt-SSLeay>=0 p5-Path-Class>=0.26 p5-Module-Build>=0.42050 p5-inc-latest-[0-9]* p5-CPAN-Meta>=2.142060 p5-Scalar-List-Utils>=1.33 p5-Try-Tiny>=0.19 p5-HTML-Tagset-[0-9]* p5-IO-Socket-SSL-[0-9]* p5-Test-Fatal-[0-9]* p5-Try-Tiny>=0.07 p5-Test-RequiresInternet-[0-9]* p5-URI>=1.37 hal>=0.5.14nb8 system-tools-backends>=2.6.1nb7 .

This package requires the following package(s) to run: hal>=0.5.11 pciids-[0-9]* libvolume_id>=0.81.0 glib2>=2.4.0 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.0.11 usbids>=20081118 policykit>=0.9 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 dbus>=0.91 dbus-glib>=0.61 glib2>=2.40 dbus>=1.8 glib2>=2.34.0 libxml2>=2.8.0nb2 dbus-glib>=0.100nb1 hal-info>=20081022 policykit>=0.9nb12 system-tools-backends>=2.6.0 p5-XML-Twig>=3.32 p5-XML-Parser>=2.23 perl>=5.30.0 perl<5.32.0 p5-Net-DBus>=0.33.6 p5-XML-Twig-[0-9]* dbus>=1.0.0 p5-libwww>=5.820 p5-Encode-Locale>=0 p5-File-Listing>=6 p5-HTTP-Date>=6.00 p5-HTTP-Cookies>=6 p5-HTTP-Message>=6.02 p5-URI-[0-9]* p5-HTML-Parser>=3.33 p5-HTML-Tagset>=3.0 p5-HTTP-Date>=6 p5-Encode-Locale>=1.02 p5-LWP-MediaTypes>=6.01 p5-IO-HTML-[0-9]* p5-Try-Tiny-[0-9]* p5-HTTP-Daemon>=6 p5-HTTP-Negotiate>=6 p5-HTTP-Message>=6 p5-LWP-MediaTypes>=6 p5-Net-HTTP>=6.18 p5-URI>=1.10 p5-WWW-RobotRules>=6.01 p5-URI>=1.27 p5-LWP-Protocol-https>=6.02 p5-IO-Socket-SSL>=1.38 p5-IO-Socket-INET6-[0-9]* p5-Socket6>=0.12 p5-Net-LibIDN-[0-9]* libidn>=0.4.6 libidn>=1.20nb1 p5-Net-SSLeay>=1.59 p5-Mozilla-CA-[0-9]* p5-Mozilla-CA>=20110101 p5-Crypt-SSLeay>=0 p5-Path-Class>=0.26 p5-Try-Tiny>=0.19 p5-HTML-Tagset-[0-9]* p5-IO-Socket-SSL-[0-9]* p5-URI>=1.37 hal>=0.5.14nb8 system-tools-backends>=2.6.1nb7 .

This package supports the following build-time options:

hal
Support for the freedesktop.org Hardware Abstraction Layer.

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
alpha:liboobs-2.22.2nb10.tgz(NetBSD 8.0)
alpha:liboobs-2.22.2nb10.tgz(NetBSD 8.0)
alpha:liboobs-2.22.2nb10.tgz(NetBSD 8.0)
earm:liboobs-2.22.2nb8.tgz(NetBSD 7.0)
earm:liboobs-2.22.2nb10.tgz(NetBSD 8.0)
earm:liboobs-2.22.2nb10.tgz(NetBSD 8.0)
earm:liboobs-2.22.2nb10.tgz(NetBSD 8.0)
earmv4:liboobs-2.22.2nb10.tgz(NetBSD 8.0)
earmv6hf:liboobs-2.22.2nb8.tgz(NetBSD 7.0)
earmv6hf:liboobs-2.22.2nb10.tgz(NetBSD 8.0)
earmv6hf:liboobs-2.22.2nb10.tgz(NetBSD 8.0)
earmv7hf:liboobs-2.22.2nb8.tgz(NetBSD 7.0)
earmv7hf:liboobs-2.22.2nb10.tgz(NetBSD 8.0)
earmv7hf:liboobs-2.22.2nb10.tgz(NetBSD 8.0)
i386:liboobs-2.22.2nb9.tgz(NetBSD 6.0)
i386:liboobs-2.22.2nb10.tgz(NetBSD 7.0)
i386:liboobs-2.22.2nb9.tgz(NetBSD 7.0)
i386:liboobs-2.22.2nb10.tgz(NetBSD 7.0)
i386:liboobs-2.22.2nb10.tgz(NetBSD 7.0)
i386:liboobs-2.22.2nb10.tgz(NetBSD 7.0)
i386:liboobs-2.22.2nb10.tgz(NetBSD 7.1)
i386:liboobs-2.22.2nb9.tgz(NetBSD 7.1)
i386:liboobs-2.22.2nb10.tgz(NetBSD 7.1)
i386:liboobs-2.22.2nb10.tgz(NetBSD 7.1)
i386:liboobs-2.22.2nb10.tgz(NetBSD 7.1)
i386:liboobs-2.22.2nb10.tgz(NetBSD 8.0)
i386:liboobs-2.22.2nb9.tgz(NetBSD 8.0)
i386:liboobs-2.22.2nb10.tgz(NetBSD 8.0)
i386:liboobs-2.22.2nb10.tgz(NetBSD 8.0)
i386:liboobs-2.22.2nb10.tgz(NetBSD 8.0)
mips64eb:liboobs-2.22.2nb10.tgz(NetBSD 8.0)
mips64eb:liboobs-2.22.2nb10.tgz(NetBSD 8.0)
powerpc:liboobs-2.22.2nb10.tgz(NetBSD 7.1)
powerpc:liboobs-2.22.2nb10.tgz(NetBSD 8.0)
powerpc:liboobs-2.22.2nb10.tgz(NetBSD 9.0)
sparc64:liboobs-2.22.2nb9.tgz(NetBSD 7.1)
sparc64:liboobs-2.22.2nb10.tgz(NetBSD 8.0)
sparc64:liboobs-2.22.2nb10.tgz(NetBSD 8.0)
sparc:liboobs-2.22.2nb9.tgz(NetBSD 7.0)
sparc:liboobs-2.22.2nb10.tgz(NetBSD 8.0)
sparc:liboobs-2.22.2nb10.tgz(NetBSD 8.0)
x86_64:liboobs-2.22.2nb10.tgz(NetBSD 7.0)
x86_64:liboobs-2.22.2nb9.tgz(NetBSD 7.0)
x86_64:liboobs-2.22.2nb10.tgz(NetBSD 7.0)
x86_64:liboobs-2.22.2nb10.tgz(NetBSD 7.0)
x86_64:liboobs-2.22.2nb10.tgz(NetBSD 7.0)
x86_64:liboobs-2.22.2nb10.tgz(NetBSD 7.1)
x86_64:liboobs-2.22.2nb9.tgz(NetBSD 7.1)
x86_64:liboobs-2.22.2nb10.tgz(NetBSD 7.1)
x86_64:liboobs-2.22.2nb10.tgz(NetBSD 7.1)
x86_64:liboobs-2.22.2nb10.tgz(NetBSD 7.1)
x86_64:liboobs-2.22.2nb10.tgz(NetBSD 8.0)
x86_64:liboobs-2.22.2nb9.tgz(NetBSD 8.0)
x86_64:liboobs-2.22.2nb10.tgz(NetBSD 8.0)
x86_64:liboobs-2.22.2nb10.tgz(NetBSD 8.0)
x86_64:liboobs-2.22.2nb10.tgz(NetBSD 8.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]