sysutils/tcx - The NetBSD Packages Collection

Transparently compress executables

TCX is a system designed for the transparent decompression, execution
and recompression of executables under Unix.  It allows configuration
options such as the type of compression system used (compress(1),
gzip(1), your own local system etc), timeouts between recompressions,
and emergency directories in case a decompression fails from shortage
of disk space.  The system is designed with a reasonable amount of
robustness in mind, such as in the event of system crashes, or races
on trying to uncompress, compress or execute something.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hftcx-19940124.tgz
NetBSD 8.0earmv7hftcx-19940124.tgz
NetBSD 8.0earmv7hftcx-19940124.tgz
NetBSD 8.0i386tcx-19940124.tgz
NetBSD 8.0i386tcx-19940124.tgz
NetBSD 8.0i386tcx-19940124.tgz
NetBSD 8.0powerpctcx-19940124.tgz
NetBSD 8.0powerpctcx-19940124.tgz
NetBSD 8.0powerpctcx-19940124.tgz
NetBSD 8.0x86_64tcx-19940124.tgz
NetBSD 8.0x86_64tcx-19940124.tgz
NetBSD 8.0x86_64tcx-19940124.tgz
NetBSD 9.0aarch64tcx-19940124.tgz
NetBSD 9.0aarch64tcx-19940124.tgz
NetBSD 9.0aarch64tcx-19940124.tgz
NetBSD 9.0alphatcx-19940124.tgz
NetBSD 9.0alphatcx-19940124.tgz
NetBSD 9.0alphatcx-19940124.tgz
NetBSD 9.0earmv6hftcx-19940124.tgz
NetBSD 9.0earmv6hftcx-19940124.tgz
NetBSD 9.0earmv6hftcx-19940124.tgz
NetBSD 9.0earmv6hftcx-19940124.tgz
NetBSD 9.0earmv7hftcx-19940124.tgz
NetBSD 9.0earmv7hftcx-19940124.tgz
NetBSD 9.0earmv7hftcx-19940124.tgz
NetBSD 9.0earmv7hftcx-19940124.tgz
NetBSD 9.0i386tcx-19940124.tgz
NetBSD 9.0i386tcx-19940124.tgz
NetBSD 9.0i386tcx-19940124.tgz
NetBSD 9.0mips64ebtcx-19940124.tgz
NetBSD 9.0mips64ebtcx-19940124.tgz
NetBSD 9.0mips64ebtcx-19940124.tgz
NetBSD 9.0powerpctcx-19940124.tgz
NetBSD 9.0powerpctcx-19940124.tgz
NetBSD 9.0sparc64tcx-19940124.tgz
NetBSD 9.0sparc64tcx-19940124.tgz
NetBSD 9.0sparc64tcx-19940124.tgz
NetBSD 9.0sparc64tcx-19940124.tgz
NetBSD 9.0sparctcx-19940124.tgz
NetBSD 9.0x86_64tcx-19940124.tgz
NetBSD 9.0x86_64tcx-19940124.tgz
NetBSD 9.0x86_64tcx-19940124.tgz
NetBSD 9.0x86_64tcx-19940124.tgz
NetBSD 9.0x86_64tcx-19940124.tgz
NetBSD 9.0x86_64tcx-19940124.tgz
NetBSD 9.0x86_64tcx-19940124.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.