textproc/enchant2 - The NetBSD Packages Collection

Generic spell checking library

The project aims to provide an efficient extensible abstraction
for dealing with different spell checking libraries.

Enchant is meant to provide a generic interface into various existing
spell checking libraries. These include, but are not limited to:
	* Aspell/Pspell (intends to replace Ispell)
	* Hunspell (an OOo project, also used by Mozilla)
	* Uspell (primarily Yiddish, Hebrew, and Eastern European
	  languages - hosted in AbiWord's CVS under the module "uspell")
	* Hspell (Hebrew)
	* Zemberek (Turkish)
	* Voikko (Finnish)
	* AppleSpell (Mac OSX)

Enchant is also meant to be used in a cross-platform (XP) environment.
Part of this means that Enchant wants to limit its number of external
dependencies to 0, or as close is as humanly possible. Also, any
enchant consumer (i.e. a Word Processor) should not need to know
about what backend providers Enchant knows about. In fact, Enchant
shouldn't even need to know this information itself. To accomplish
this, all of Enchant's providers are DLLs.

Build dependencies

devel/unittest-cpp pkgtools/cwrappers devel/glib2-tools devel/libtool-base devel/autoconf devel/pkgconf

Runtime dependencies

textproc/hunspell-en_US textproc/hunspell devel/glib2 textproc/hunspell devel/glib2

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfenchant2-2.2.13.tgz
NetBSD 8.0earmv7hfenchant2-2.2.11.tgz
NetBSD 8.0earmv7hfenchant2-2.2.15.tgz
NetBSD 8.0i386enchant2-2.2.11.tgz
NetBSD 8.0i386enchant2-2.2.13.tgz
NetBSD 8.0i386enchant2-2.2.15.tgz
NetBSD 8.0powerpcenchant2-2.2.11.tgz
NetBSD 8.0powerpcenchant2-2.2.15.tgz
NetBSD 8.0powerpcenchant2-2.2.13.tgz
NetBSD 8.0powerpcenchant2-2.2.15.tgz
NetBSD 8.0x86_64enchant2-2.2.15.tgz
NetBSD 8.0x86_64enchant2-2.2.11.tgz
NetBSD 8.0x86_64enchant2-2.2.13.tgz
NetBSD 9.0aarch64enchant2-2.2.15.tgz
NetBSD 9.0aarch64enchant2-2.2.11.tgz
NetBSD 9.0aarch64enchant2-2.2.13.tgz
NetBSD 9.0alphaenchant2-2.2.15.tgz
NetBSD 9.0alphaenchant2-2.2.11.tgz
NetBSD 9.0alphaenchant2-2.2.13.tgz
NetBSD 9.0earmenchant2-2.2.11.tgz
NetBSD 9.0earmenchant2-2.2.13.tgz
NetBSD 9.0earmenchant2-2.2.15.tgz
NetBSD 9.0earmv6hfenchant2-2.2.15.tgz
NetBSD 9.0earmv6hfenchant2-2.2.11.tgz
NetBSD 9.0earmv6hfenchant2-2.2.13.tgz
NetBSD 9.0earmv6hfenchant2-2.2.13.tgz
NetBSD 9.0earmv7hfenchant2-2.2.15.tgz
NetBSD 9.0earmv7hfenchant2-2.2.11.tgz
NetBSD 9.0earmv7hfenchant2-2.2.13.tgz
NetBSD 9.0earmv7hfenchant2-2.2.13.tgz
NetBSD 9.0earmv7hfenchant2-2.2.15.tgz
NetBSD 9.0i386enchant2-2.2.11.tgz
NetBSD 9.0i386enchant2-2.2.13.tgz
NetBSD 9.0i386enchant2-2.2.15.tgz
NetBSD 9.0m68kenchant2-2.2.15.tgz
NetBSD 9.0m68kenchant2-2.2.11.tgz
NetBSD 9.0m68kenchant2-2.2.13.tgz
NetBSD 9.0mips64ebenchant2-2.2.15.tgz
NetBSD 9.0mips64ebenchant2-2.2.11.tgz
NetBSD 9.0mips64ebenchant2-2.2.13.tgz
NetBSD 9.0mipselenchant2-2.2.13.tgz
NetBSD 9.0mipselenchant2-2.2.15.tgz
NetBSD 9.0powerpcenchant2-2.2.13.tgz
NetBSD 9.0powerpcenchant2-2.2.11.tgz
NetBSD 9.0powerpcenchant2-2.2.15.tgz
NetBSD 9.0powerpcenchant2-2.2.15.tgz
NetBSD 9.0sh3elenchant2-2.2.11.tgz
NetBSD 9.0sh3elenchant2-2.2.13.tgz
NetBSD 9.0sh3elenchant2-2.2.15.tgz
NetBSD 9.0sparc64enchant2-2.2.15.tgz
NetBSD 9.0sparc64enchant2-2.2.8nb1.tgz
NetBSD 9.0sparc64enchant2-2.2.11.tgz
NetBSD 9.0sparc64enchant2-2.2.13.tgz
NetBSD 9.0sparcenchant2-2.2.15.tgz
NetBSD 9.0sparcenchant2-2.2.11.tgz
NetBSD 9.0sparcenchant2-2.2.13.tgz
NetBSD 9.0x86_64enchant2-2.2.13.tgz
NetBSD 9.0x86_64enchant2-2.2.13.tgz
NetBSD 9.0x86_64enchant2-2.2.15.tgz
NetBSD 9.0x86_64enchant2-2.2.15.tgz
NetBSD 9.0x86_64enchant2-2.2.11.tgz
NetBSD 9.0x86_64enchant2-2.2.13.tgz
NetBSD 9.0x86_64enchant2-2.2.15.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

aspell
Add spell checking support using aspell.
enchant-zemberek
Add spell checking support for Turkish.
hunspell
Add spell checking support using hunspell.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.