textproc/go-chroma - The NetBSD Packages Collection

General purpose syntax highlighter in pure Go

Chroma - A general purpose syntax highlighter in pure Go Build
Status Gitter chat

Chroma takes source code and other structured text and converts it
into syntax highlighted HTML, ANSI-coloured text, etc.

Chroma is based heavily on Pygments, and includes translators for
Pygments lexers and styles.

Build dependencies

lang/go116 textproc/go-regexp2 devel/go-fnmatch devel/go-colorable devel/go-isatty devel/go-sys devel/go-kingpin.v3-unstable math/go-units devel/go-i18n devel/go-yaml www/go-toml-pelletier devel/go-buffruneio pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfgo-chroma-0.5.0nb21.tgz
NetBSD 8.0earmv7hfgo-chroma-0.5.0nb18.tgz
NetBSD 8.0earmv7hfgo-chroma-0.5.0nb23.tgz
NetBSD 8.0i386go-chroma-0.5.0nb18.tgz
NetBSD 8.0i386go-chroma-0.5.0nb21.tgz
NetBSD 8.0i386go-chroma-0.5.0nb23.tgz
NetBSD 8.0x86_64go-chroma-0.5.0nb23.tgz
NetBSD 8.0x86_64go-chroma-0.5.0nb18.tgz
NetBSD 9.0aarch64go-chroma-0.5.0nb23.tgz
NetBSD 9.0aarch64go-chroma-0.5.0nb18.tgz
NetBSD 9.0aarch64go-chroma-0.5.0nb21.tgz
NetBSD 9.0earmv7hfgo-chroma-0.5.0nb23.tgz
NetBSD 9.0earmv7hfgo-chroma-0.5.0nb18.tgz
NetBSD 9.0earmv7hfgo-chroma-0.5.0nb21.tgz
NetBSD 9.0i386go-chroma-0.5.0nb18.tgz
NetBSD 9.0i386go-chroma-0.5.0nb21.tgz
NetBSD 9.0i386go-chroma-0.5.0nb23.tgz
NetBSD 9.0x86_64go-chroma-0.5.0nb21.tgz
NetBSD 9.0x86_64go-chroma-0.5.0nb21.tgz
NetBSD 9.0x86_64go-chroma-0.5.0nb22.tgz
NetBSD 9.0x86_64go-chroma-0.5.0nb23.tgz
NetBSD 9.0x86_64go-chroma-0.5.0nb18.tgz
NetBSD 9.0x86_64go-chroma-0.5.0nb21.tgz
NetBSD 9.0x86_64go-chroma-0.5.0nb23.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.