textproc/ocaml-uutf - The NetBSD Packages Collection

Unicode library for OCaml

Uutf is an non-blocking streaming Unicode codec for OCaml to decode and encode
the UTF-8, UTF-16, UTF-16LE and UTF-16BE encoding schemes.

Build dependencies

devel/ocamlbuild pkgtools/cwrappers devel/ocamlbuild

Runtime dependencies

misc/ocaml-topkg devel/ocaml-findlib lang/ocaml devel/ocaml-cmdliner textproc/ocaml-uchar misc/ocaml-topkg devel/ocaml-findlib devel/ocaml-cmdliner textproc/ocaml-uchar

Binary packages

OSArchitectureVersion
NetBSD 8.0i386ocaml-uutf-1.0.2.tgz
NetBSD 8.0i386ocaml-uutf-1.0.2.tgz
NetBSD 8.0i386ocaml-uutf-1.0.2nb1.tgz
NetBSD 8.0powerpcocaml-uutf-1.0.2nb1.tgz
NetBSD 8.0powerpcocaml-uutf-1.0.2.tgz
NetBSD 8.0powerpcocaml-uutf-1.0.2nb1.tgz
NetBSD 8.0x86_64ocaml-uutf-1.0.2nb1.tgz
NetBSD 8.0x86_64ocaml-uutf-1.0.2.tgz
NetBSD 8.0x86_64ocaml-uutf-1.0.2.tgz
NetBSD 9.0aarch64ocaml-uutf-1.0.2nb1.tgz
NetBSD 9.0aarch64ocaml-uutf-1.0.2.tgz
NetBSD 9.0aarch64ocaml-uutf-1.0.2.tgz
NetBSD 9.0earmv6hfocaml-uutf-1.0.2nb1.tgz
NetBSD 9.0earmv6hfocaml-uutf-1.0.2.tgz
NetBSD 9.0earmv6hfocaml-uutf-1.0.2.tgz
NetBSD 9.0earmv7hfocaml-uutf-1.0.2nb1.tgz
NetBSD 9.0earmv7hfocaml-uutf-1.0.2.tgz
NetBSD 9.0earmv7hfocaml-uutf-1.0.2.tgz
NetBSD 9.0earmv7hfocaml-uutf-1.0.2nb1.tgz
NetBSD 9.0i386ocaml-uutf-1.0.2.tgz
NetBSD 9.0i386ocaml-uutf-1.0.2.tgz
NetBSD 9.0i386ocaml-uutf-1.0.2nb1.tgz
NetBSD 9.0powerpcocaml-uutf-1.0.2.tgz
NetBSD 9.0powerpcocaml-uutf-1.0.2nb1.tgz
NetBSD 9.0powerpcocaml-uutf-1.0.2nb1.tgz
NetBSD 9.0x86_64ocaml-uutf-1.0.2.tgz
NetBSD 9.0x86_64ocaml-uutf-1.0.2.tgz
NetBSD 9.0x86_64ocaml-uutf-1.0.2.tgz
NetBSD 9.0x86_64ocaml-uutf-1.0.2nb1.tgz
NetBSD 9.0x86_64ocaml-uutf-1.0.2.tgz
NetBSD 9.0x86_64ocaml-uutf-1.0.2.tgz
NetBSD 9.0x86_64ocaml-uutf-1.0.2nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.