www/ap-auth-mellon - The NetBSD Packages Collection

Module to allow Apache authentication using a SAML 2.0 IdP

mod_auth_mellon is a authentication module for Apache. It authenticates
the user against a SAML 2.0 IdP, and grants access to directories
depending on attributes received from the IdP.

Build dependencies

pkgtools/cwrappers devel/glib2-tools devel/libtool-base devel/gmake lang/perl5 devel/pkgconf

Runtime dependencies

devel/glib2 www/apache24 security/lasso devel/glib2 www/curl www/apache24 security/lasso devel/glib2 www/curl

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfap24-auth-mellon-0.13.1nb15.tgz
NetBSD 8.0earmv7hfap24-auth-mellon-0.13.1nb15.tgz
NetBSD 8.0i386ap24-auth-mellon-0.13.1nb14.tgz
NetBSD 8.0i386ap24-auth-mellon-0.13.1nb15.tgz
NetBSD 8.0i386ap24-auth-mellon-0.13.1nb15.tgz
NetBSD 8.0powerpcap24-auth-mellon-0.13.1nb11.tgz
NetBSD 8.0powerpcap24-auth-mellon-0.13.1nb14.tgz
NetBSD 8.0powerpcap24-auth-mellon-0.13.1nb11.tgz
NetBSD 8.0powerpcap24-auth-mellon-0.13.1nb14.tgz
NetBSD 8.0powerpcap24-auth-mellon-0.13.1nb15.tgz
NetBSD 8.0powerpcap24-auth-mellon-0.13.1nb11.tgz
NetBSD 8.0powerpcap24-auth-mellon-0.13.1nb14.tgz
NetBSD 8.0powerpcap24-auth-mellon-0.13.1nb15.tgz
NetBSD 8.0x86_64ap24-auth-mellon-0.13.1nb15.tgz
NetBSD 8.0x86_64ap24-auth-mellon-0.13.1nb14.tgz
NetBSD 8.0x86_64ap24-auth-mellon-0.13.1nb15.tgz
NetBSD 9.0aarch64ap24-auth-mellon-0.13.1nb15.tgz
NetBSD 9.0aarch64ap24-auth-mellon-0.13.1nb14.tgz
NetBSD 9.0aarch64ap24-auth-mellon-0.13.1nb15.tgz
NetBSD 9.0alphaap24-auth-mellon-0.13.1nb15.tgz
NetBSD 9.0alphaap24-auth-mellon-0.13.1nb14.tgz
NetBSD 9.0alphaap24-auth-mellon-0.13.1nb15.tgz
NetBSD 9.0earmv6hfap24-auth-mellon-0.13.1nb15.tgz
NetBSD 9.0earmv6hfap24-auth-mellon-0.13.1nb14.tgz
NetBSD 9.0earmv6hfap24-auth-mellon-0.13.1nb15.tgz
NetBSD 9.0earmv6hfap24-auth-mellon-0.13.1nb15.tgz
NetBSD 9.0earmv7hfap24-auth-mellon-0.13.1nb15.tgz
NetBSD 9.0earmv7hfap24-auth-mellon-0.13.1nb14.tgz
NetBSD 9.0earmv7hfap24-auth-mellon-0.13.1nb15.tgz
NetBSD 9.0earmv7hfap24-auth-mellon-0.13.1nb15.tgz
NetBSD 9.0i386ap24-auth-mellon-0.13.1nb14.tgz
NetBSD 9.0i386ap24-auth-mellon-0.13.1nb15.tgz
NetBSD 9.0i386ap24-auth-mellon-0.13.1nb15.tgz
NetBSD 9.0mips64ebap24-auth-mellon-0.13.1nb14.tgz
NetBSD 9.0powerpcap24-auth-mellon-0.13.1nb11.tgz
NetBSD 9.0powerpcap24-auth-mellon-0.13.1nb14.tgz
NetBSD 9.0powerpcap24-auth-mellon-0.13.1nb15.tgz
NetBSD 9.0powerpcap24-auth-mellon-0.13.1nb11.tgz
NetBSD 9.0powerpcap24-auth-mellon-0.13.1nb14.tgz
NetBSD 9.0sparc64ap24-auth-mellon-0.13.1nb15.tgz
NetBSD 9.0sparc64ap24-auth-mellon-0.13.1nb14.tgz
NetBSD 9.0sparc64ap24-auth-mellon-0.13.1nb15.tgz
NetBSD 9.0x86_64ap24-auth-mellon-0.13.1nb15.tgz
NetBSD 9.0x86_64ap24-auth-mellon-0.13.1nb15.tgz
NetBSD 9.0x86_64ap24-auth-mellon-0.13.1nb15.tgz
NetBSD 9.0x86_64ap24-auth-mellon-0.13.1nb15.tgz
NetBSD 9.0x86_64ap24-auth-mellon-0.13.1nb14.tgz
NetBSD 9.0x86_64ap24-auth-mellon-0.13.1nb15.tgz
NetBSD 9.0x86_64ap24-auth-mellon-0.13.1nb15.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.