x11/libXfixes - The NetBSD Packages Collection

Xfixes library and extension of X RandR from modular X.org

The X Fixes Extension provides workarounds for various limitations
in the core protocol.  The extension is designed to hold various
vaguely related extension bits that change how the X server and
clients interact with fundamental parts of the window system.

This package provides the libXFixes library from the modular X.org
X11 project.

Build dependencies

pkgtools/x11-links x11/xorgproto pkgtools/cwrappers devel/libtool-base devel/pkgconf

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflibXfixes-5.0.3nb1.tgz
NetBSD 8.0earmv7hflibXfixes-5.0.3nb1.tgz
NetBSD 8.0earmv7hflibXfixes-5.0.3nb1.tgz
NetBSD 8.0i386libXfixes-5.0.3nb1.tgz
NetBSD 8.0i386libXfixes-5.0.3nb1.tgz
NetBSD 8.0i386libXfixes-5.0.3nb1.tgz
NetBSD 8.0powerpclibXfixes-5.0.3nb1.tgz
NetBSD 8.0powerpclibXfixes-5.0.3nb1.tgz
NetBSD 8.0powerpclibXfixes-5.0.3nb1.tgz
NetBSD 8.0x86_64libXfixes-5.0.3nb1.tgz
NetBSD 8.0x86_64libXfixes-5.0.3nb1.tgz
NetBSD 8.0x86_64libXfixes-5.0.3nb1.tgz
NetBSD 9.0aarch64libXfixes-5.0.3nb1.tgz
NetBSD 9.0aarch64libXfixes-5.0.3nb1.tgz
NetBSD 9.0aarch64libXfixes-5.0.3nb1.tgz
NetBSD 9.0alphalibXfixes-5.0.3nb1.tgz
NetBSD 9.0alphalibXfixes-5.0.3nb1.tgz
NetBSD 9.0alphalibXfixes-5.0.3nb1.tgz
NetBSD 9.0earmv6hflibXfixes-5.0.3nb1.tgz
NetBSD 9.0earmv6hflibXfixes-5.0.3nb1.tgz
NetBSD 9.0earmv6hflibXfixes-5.0.3nb1.tgz
NetBSD 9.0earmv6hflibXfixes-5.0.3nb1.tgz
NetBSD 9.0earmv7hflibXfixes-5.0.3nb1.tgz
NetBSD 9.0earmv7hflibXfixes-5.0.3nb1.tgz
NetBSD 9.0earmv7hflibXfixes-5.0.3nb1.tgz
NetBSD 9.0earmv7hflibXfixes-5.0.3nb1.tgz
NetBSD 9.0i386libXfixes-5.0.3nb1.tgz
NetBSD 9.0i386libXfixes-5.0.3nb1.tgz
NetBSD 9.0i386libXfixes-5.0.3nb1.tgz
NetBSD 9.0mips64eblibXfixes-5.0.3nb1.tgz
NetBSD 9.0mips64eblibXfixes-5.0.3nb1.tgz
NetBSD 9.0powerpclibXfixes-5.0.3nb1.tgz
NetBSD 9.0powerpclibXfixes-5.0.3nb1.tgz
NetBSD 9.0sparc64libXfixes-5.0.3nb1.tgz
NetBSD 9.0sparc64libXfixes-5.0.3nb1.tgz
NetBSD 9.0sparc64libXfixes-5.0.3nb1.tgz
NetBSD 9.0sparc64libXfixes-5.0.3nb1.tgz
NetBSD 9.0sparclibXfixes-5.0.3nb1.tgz
NetBSD 9.0sparclibXfixes-5.0.3nb1.tgz
NetBSD 9.0x86_64libXfixes-5.0.3nb1.tgz
NetBSD 9.0x86_64libXfixes-5.0.3nb1.tgz
NetBSD 9.0x86_64libXfixes-5.0.3nb1.tgz
NetBSD 9.0x86_64libXfixes-5.0.3nb1.tgz
NetBSD 9.0x86_64libXfixes-5.0.3nb1.tgz
NetBSD 9.0x86_64libXfixes-5.0.3nb1.tgz
NetBSD 9.0x86_64libXfixes-5.0.3nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.