x11/ocaml-lablgtk3 - The NetBSD Packages Collection

GTK+ 3.x bindings for OCaml

LablGTK is an Objective Caml interface to GTK+.  This version
supports GTK+ version 3.x.

It uses the rich type system of Objective Caml to provide a
strongly typed, yet very comfortable, object-oriented interface to
GTK+.  This is not that easy if you know the dynamic typing approach
taken by GTK+.

Build dependencies

pkgtools/x11-links misc/ocaml-opaline x11/xorgproto x11/xcb-proto pkgtools/cwrappers misc/ocaml-opaline devel/glib2-tools devel/pkgconf

Runtime dependencies

devel/ocaml-dune devel/ocaml-findlib lang/ocaml textproc/gtkspell3 x11/gtk3 x11/gtksourceview3 graphics/ocaml-cairo devel/ocaml-dune devel/ocaml-findlib textproc/gtkspell3 x11/gtk3 x11/gtksourceview3 graphics/ocaml-cairo

Binary packages

OSArchitectureVersion
NetBSD 8.0x86_64ocaml-lablgtk3-3.1.0nb6.tgz
NetBSD 8.0x86_64ocaml-lablgtk3-3.1.0nb4.tgz
NetBSD 8.0x86_64ocaml-lablgtk3-3.1.0nb5.tgz
NetBSD 9.0aarch64ocaml-lablgtk3-3.1.0nb6.tgz
NetBSD 9.0aarch64ocaml-lablgtk3-3.1.0nb4.tgz
NetBSD 9.0aarch64ocaml-lablgtk3-3.1.0nb5.tgz
NetBSD 9.0earmv6hfocaml-lablgtk3-3.1.0nb6.tgz
NetBSD 9.0earmv6hfocaml-lablgtk3-3.1.0nb5.tgz
NetBSD 9.0earmv6hfocaml-lablgtk3-3.1.0nb5.tgz
NetBSD 9.0earmv7hfocaml-lablgtk3-3.1.0nb6.tgz
NetBSD 9.0earmv7hfocaml-lablgtk3-3.1.0nb5.tgz
NetBSD 9.0earmv7hfocaml-lablgtk3-3.1.0nb5.tgz
NetBSD 9.0i386ocaml-lablgtk3-3.1.0nb4.tgz
NetBSD 9.0i386ocaml-lablgtk3-3.1.0nb5.tgz
NetBSD 9.0i386ocaml-lablgtk3-3.1.0nb6.tgz
NetBSD 9.0powerpcocaml-lablgtk3-3.1.0nb5.tgz
NetBSD 9.0x86_64ocaml-lablgtk3-3.1.0nb5.tgz
NetBSD 9.0x86_64ocaml-lablgtk3-3.1.0nb5.tgz
NetBSD 9.0x86_64ocaml-lablgtk3-3.1.0nb5.tgz
NetBSD 9.0x86_64ocaml-lablgtk3-3.1.0nb4.tgz
NetBSD 9.0x86_64ocaml-lablgtk3-3.1.0nb5.tgz
NetBSD 9.0x86_64ocaml-lablgtk3-3.1.0nb6.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

gtksourceview3
Enable gtksourceview3 support.
gtkspell
Enable gtkspell support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.