x11/qtermwidget - The NetBSD Packages Collection

Terminal emulator widget for Qt5

A terminal emulator widget for Qt 5.
QTermWidget is an open-source project originally based on the
KDE4 Konsole application, but it took its own direction later on.
The main goal of this project is to provide a Unicode-enabled,
embeddable Qt widget for using as a built-in console
(or terminal emulation widget).
It is compatible with BSD, Linux and OS X.

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/lxqt-build-tools x11/qt5-qttools devel/glib2-tools devel/cmake devel/pkgconf

Runtime dependencies

x11/qt5-qtbase x11/qt5-qtbase

Binary packages

OSArchitectureVersion
NetBSD 8.0i386qtermwidget-0.15.0nb2.tgz
NetBSD 8.0powerpcqtermwidget-0.15.0nb2.tgz
NetBSD 8.0x86_64qtermwidget-0.15.0nb2.tgz
NetBSD 8.0x86_64qtermwidget-0.16.1.tgz
NetBSD 9.0aarch64qtermwidget-0.16.1.tgz
NetBSD 9.0aarch64qtermwidget-0.15.0nb2.tgz
NetBSD 9.0aarch64qtermwidget-0.16.1.tgz
NetBSD 9.0earmv7hfqtermwidget-0.15.0nb2.tgz
NetBSD 9.0i386qtermwidget-0.15.0nb2.tgz
NetBSD 9.0i386qtermwidget-0.16.1.tgz
NetBSD 9.0powerpcqtermwidget-0.16.1.tgz
NetBSD 9.0sparc64qtermwidget-0.15.0nb1.tgz
NetBSD 9.0sparc64qtermwidget-0.15.0nb2.tgz
NetBSD 9.0x86_64qtermwidget-0.15.0nb3.tgz
NetBSD 9.0x86_64qtermwidget-0.16.1.tgz
NetBSD 9.0x86_64qtermwidget-0.16.1.tgz
NetBSD 9.0x86_64qtermwidget-0.15.0nb2.tgz
NetBSD 9.0x86_64qtermwidget-0.16.1.tgz
NetBSD 9.0x86_64qtermwidget-0.16.1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.