x11/x2x - The NetBSD Packages Collection

One keyboard and mouse to control multiple X displays

x2x allows the keyboard and mouse on one ("from") X display
to be used to control another ("to") X display.

Build dependencies

pkgtools/x11-links x11/xorgproto pkgtools/cwrappers devel/imake

Runtime dependencies

x11/libXtst

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfx2x-1.27nb2.tgz
NetBSD 8.0earmv7hfx2x-1.27nb2.tgz
NetBSD 8.0earmv7hfx2x-1.27nb2.tgz
NetBSD 8.0i386x2x-1.27nb2.tgz
NetBSD 8.0i386x2x-1.27nb2.tgz
NetBSD 8.0i386x2x-1.27nb2.tgz
NetBSD 8.0powerpcx2x-1.27nb2.tgz
NetBSD 8.0powerpcx2x-1.27nb2.tgz
NetBSD 8.0powerpcx2x-1.27nb2.tgz
NetBSD 8.0x86_64x2x-1.27nb2.tgz
NetBSD 8.0x86_64x2x-1.27nb2.tgz
NetBSD 9.0aarch64x2x-1.27nb2.tgz
NetBSD 9.0aarch64x2x-1.27nb2.tgz
NetBSD 9.0aarch64x2x-1.27nb2.tgz
NetBSD 9.0alphax2x-1.27nb2.tgz
NetBSD 9.0alphax2x-1.27nb2.tgz
NetBSD 9.0alphax2x-1.27nb2.tgz
NetBSD 9.0earmv6hfx2x-1.27nb2.tgz
NetBSD 9.0earmv6hfx2x-1.27nb2.tgz
NetBSD 9.0earmv6hfx2x-1.27nb2.tgz
NetBSD 9.0earmv6hfx2x-1.27nb2.tgz
NetBSD 9.0earmv7hfx2x-1.27nb2.tgz
NetBSD 9.0earmv7hfx2x-1.27nb2.tgz
NetBSD 9.0earmv7hfx2x-1.27nb2.tgz
NetBSD 9.0earmv7hfx2x-1.27nb2.tgz
NetBSD 9.0i386x2x-1.27nb2.tgz
NetBSD 9.0i386x2x-1.27nb2.tgz
NetBSD 9.0i386x2x-1.27nb2.tgz
NetBSD 9.0mips64ebx2x-1.27nb2.tgz
NetBSD 9.0mips64ebx2x-1.27nb2.tgz
NetBSD 9.0mips64ebx2x-1.27nb2.tgz
NetBSD 9.0powerpcx2x-1.27nb2.tgz
NetBSD 9.0powerpcx2x-1.27nb2.tgz
NetBSD 9.0sparc64x2x-1.27nb2.tgz
NetBSD 9.0sparc64x2x-1.27nb2.tgz
NetBSD 9.0sparc64x2x-1.27nb2.tgz
NetBSD 9.0sparcx2x-1.27nb2.tgz
NetBSD 9.0sparcx2x-1.27nb2.tgz
NetBSD 9.0sparcx2x-1.27nb2.tgz
NetBSD 9.0x86_64x2x-1.27nb2.tgz
NetBSD 9.0x86_64x2x-1.27nb2.tgz
NetBSD 9.0x86_64x2x-1.27nb2.tgz
NetBSD 9.0x86_64x2x-1.27nb2.tgz
NetBSD 9.0x86_64x2x-1.27nb2.tgz
NetBSD 9.0x86_64x2x-1.27nb2.tgz
NetBSD 9.0x86_64x2x-1.27nb2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.