Daemon Power

The NetBSD Packages Collection: textproc/php-excel

Brief description of the package:
Pure PHP library for reading and writing spreadsheet files

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://github.com/PHPOffice/PHPExcel.

Please note that this package has a gnu-lgpl-v2 license.

The package is located in the "textproc/php-excel" directory. The current source version of the package is "php71-excel-1.8.1". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for textproc/php-excel :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: php71-gd-[0-9]* gd>=2.0.15nb1 perl>=5.0 cwrappers>=20150314 tiff>=3.6.1 jbigkit>=2.0 jpeg>=8nb1 jpeg>=9 fontconfig>=2.10.93 libuuid>=2.18 freetype2>=2.8.1 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 gperf-[0-9]* fontconfig>=2.1nb2 libimagequant>=2.8.2 libwebp>=0.2.0 giflib>=5.1.0 png>=1.2.4 tiff>=4.0.3nb5 png>=1.6.0nb1 fontconfig>=2.13.0 libwebp>=0.6.0 php>=7.0.99<7.1.99 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 readline>=2.2 libxml2>=2.8.0nb2 readline>=6.0 gd>=2.2.5nb2 php71-zip-[0-9]* libzip>=0.7.1 libzip>=1.5.1nb1 .

This package requires the following package(s) to run: php71-gd-[0-9]* gd>=2.0.15nb1 perl>=5.0 tiff>=3.6.1 jbigkit>=2.0 jpeg>=8nb1 jpeg>=9 fontconfig>=2.10.93 libuuid>=2.18 freetype2>=2.8.1 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 fontconfig>=2.1nb2 libimagequant>=2.8.2 libwebp>=0.2.0 giflib>=5.1.0 png>=1.2.4 tiff>=4.0.3nb5 png>=1.6.0nb1 fontconfig>=2.13.0 libwebp>=0.6.0 php>=7.0.99<7.1.99 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 readline>=2.2 libxml2>=2.8.0nb2 readline>=6.0 gd>=2.2.5nb2 php71-zip-[0-9]* libzip>=0.7.1 libzip>=1.5.1nb1 .

This package supports the following build-time options:

gd
Use GD to render graphical output.
zip

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
alpha:php56-excel-1.8.0.tgz(NetBSD 7.0)
alpha:php70-excel-1.8.0.tgz(NetBSD 7.0)
earm:php55-excel-1.8.0.tgz(NetBSD 7.0)
earm:php56-excel-1.8.0.tgz(NetBSD 7.0)
earm:php70-excel-1.8.0.tgz(NetBSD 7.0)
earm:php55-excel-1.8.0.tgz(NetBSD 7.0)
earm:php56-excel-1.8.0.tgz(NetBSD 7.0)
earm:php70-excel-1.8.0.tgz(NetBSD 7.0)
earmv6hf:php55-excel-1.8.0.tgz(NetBSD 7.0)
earmv6hf:php56-excel-1.8.0.tgz(NetBSD 7.0)
earmv6hf:php70-excel-1.8.0.tgz(NetBSD 7.0)
earmv6hf:php56-excel-1.8.1.tgz(NetBSD 8.0)
earmv6hf:php70-excel-1.8.1.tgz(NetBSD 8.0)
earmv6hf:php71-excel-1.8.1.tgz(NetBSD 8.0)
earmv6hf:php56-excel-1.8.1.tgz(NetBSD 8.0)
earmv6hf:php70-excel-1.8.1.tgz(NetBSD 8.0)
earmv6hf:php71-excel-1.8.1.tgz(NetBSD 8.0)
earmv6hf:php72-excel-1.8.1.tgz(NetBSD 8.0)
earmv7hf:php55-excel-1.8.0.tgz(NetBSD 7.0)
earmv7hf:php56-excel-1.8.0.tgz(NetBSD 7.0)
earmv7hf:php70-excel-1.8.0.tgz(NetBSD 7.0)
earmv7hf:php56-excel-1.8.1.tgz(NetBSD 8.0)
earmv7hf:php70-excel-1.8.1.tgz(NetBSD 8.0)
earmv7hf:php71-excel-1.8.1.tgz(NetBSD 8.0)
earmv7hf:php72-excel-1.8.1.tgz(NetBSD 8.0)
i386:php56-excel-1.8.0.tgz(NetBSD 6.0)
i386:php70-excel-1.8.0.tgz(NetBSD 6.0)
i386:php71-excel-1.8.0.tgz(NetBSD 6.0)
i386:php56-excel-1.8.1.tgz(NetBSD 6.0)
i386:php70-excel-1.8.1.tgz(NetBSD 6.0)
i386:php71-excel-1.8.1.tgz(NetBSD 6.0)
i386:php72-excel-1.8.1.tgz(NetBSD 6.0)
i386:php56-excel-1.8.0.tgz(NetBSD 6.1)
i386:php70-excel-1.8.0.tgz(NetBSD 6.1)
i386:php71-excel-1.8.0.tgz(NetBSD 6.1)
i386:php56-excel-1.8.1.tgz(NetBSD 7.0)
i386:php70-excel-1.8.1.tgz(NetBSD 7.0)
i386:php71-excel-1.8.1.tgz(NetBSD 7.0)
i386:php72-excel-1.8.1.tgz(NetBSD 7.0)
i386:php56-excel-1.8.0.tgz(NetBSD 7.0)
i386:php70-excel-1.8.0.tgz(NetBSD 7.0)
i386:php71-excel-1.8.0.tgz(NetBSD 7.0)
i386:php56-excel-1.8.1.tgz(NetBSD 7.0)
i386:php56-excel-1.8.1.tgz(NetBSD 7.0)
i386:php70-excel-1.8.1.tgz(NetBSD 7.0)
i386:php71-excel-1.8.1.tgz(NetBSD 7.0)
i386:php72-excel-1.8.1.tgz(NetBSD 7.0)
i386:php56-excel-1.8.1.tgz(NetBSD 7.0)
i386:php70-excel-1.8.1.tgz(NetBSD 7.0)
i386:php71-excel-1.8.1.tgz(NetBSD 7.0)
i386:php72-excel-1.8.1.tgz(NetBSD 7.0)
i386:php56-excel-1.8.1.tgz(NetBSD 7.1)
i386:php70-excel-1.8.1.tgz(NetBSD 7.1)
i386:php71-excel-1.8.1.tgz(NetBSD 7.1)
i386:php72-excel-1.8.1.tgz(NetBSD 7.1)
i386:php56-excel-1.8.1.tgz(NetBSD 7.1)
i386:php70-excel-1.8.1.tgz(NetBSD 7.1)
i386:php71-excel-1.8.1.tgz(NetBSD 7.1)
i386:php72-excel-1.8.1.tgz(NetBSD 7.1)
i386:php56-excel-1.8.1.tgz(NetBSD 7.1)
i386:php70-excel-1.8.1.tgz(NetBSD 7.1)
i386:php71-excel-1.8.1.tgz(NetBSD 7.1)
i386:php72-excel-1.8.1.tgz(NetBSD 7.1)
i386:php56-excel-1.8.1.tgz(NetBSD 8.0)
i386:php70-excel-1.8.1.tgz(NetBSD 8.0)
i386:php71-excel-1.8.1.tgz(NetBSD 8.0)
i386:php72-excel-1.8.1.tgz(NetBSD 8.0)
i386:php56-excel-1.8.1.tgz(NetBSD 8.0)
i386:php56-excel-1.8.1.tgz(NetBSD 8.0)
powerpc:php56-excel-1.8.0.tgz(NetBSD 6.1)
powerpc:php56-excel-1.8.1.tgz(NetBSD 6.1)
powerpc:php70-excel-1.8.0.tgz(NetBSD 6.1)
powerpc:php70-excel-1.8.1.tgz(NetBSD 6.1)
powerpc:php71-excel-1.8.0.tgz(NetBSD 6.1)
powerpc:php71-excel-1.8.1.tgz(NetBSD 6.1)
powerpc:php72-excel-1.8.1.tgz(NetBSD 6.1)
powerpc:php56-excel-1.8.0.tgz(NetBSD 6.1)
powerpc:php56-excel-1.8.1.tgz(NetBSD 6.1)
powerpc:php70-excel-1.8.0.tgz(NetBSD 6.1)
powerpc:php70-excel-1.8.1.tgz(NetBSD 6.1)
powerpc:php71-excel-1.8.0.tgz(NetBSD 6.1)
powerpc:php71-excel-1.8.1.tgz(NetBSD 6.1)
powerpc:php72-excel-1.8.1.tgz(NetBSD 6.1)
powerpc:php56-excel-1.8.0.tgz(NetBSD 7.1)
powerpc:php56-excel-1.8.1.tgz(NetBSD 7.1)
powerpc:php70-excel-1.8.0.tgz(NetBSD 7.1)
powerpc:php70-excel-1.8.1.tgz(NetBSD 7.1)
powerpc:php71-excel-1.8.0.tgz(NetBSD 7.1)
powerpc:php71-excel-1.8.1.tgz(NetBSD 7.1)
powerpc:php72-excel-1.8.1.tgz(NetBSD 7.1)
powerpc:php56-excel-1.8.0.tgz(NetBSD 7.1)
powerpc:php56-excel-1.8.1.tgz(NetBSD 7.1)
powerpc:php70-excel-1.8.0.tgz(NetBSD 7.1)
powerpc:php70-excel-1.8.1.tgz(NetBSD 7.1)
powerpc:php71-excel-1.8.0.tgz(NetBSD 7.1)
powerpc:php71-excel-1.8.1.tgz(NetBSD 7.1)
powerpc:php72-excel-1.8.1.tgz(NetBSD 7.1)
powerpc:php56-excel-1.8.0.tgz(NetBSD 8.0)
powerpc:php56-excel-1.8.1.tgz(NetBSD 8.0)
powerpc:php70-excel-1.8.0.tgz(NetBSD 8.0)
powerpc:php70-excel-1.8.1.tgz(NetBSD 8.0)
powerpc:php71-excel-1.8.0.tgz(NetBSD 8.0)
powerpc:php71-excel-1.8.1.tgz(NetBSD 8.0)
powerpc:php72-excel-1.8.1.tgz(NetBSD 8.0)
powerpc:php56-excel-1.8.0.tgz(NetBSD 8.0)
powerpc:php56-excel-1.8.1.tgz(NetBSD 8.0)
powerpc:php70-excel-1.8.0.tgz(NetBSD 8.0)
powerpc:php70-excel-1.8.1.tgz(NetBSD 8.0)
powerpc:php71-excel-1.8.0.tgz(NetBSD 8.0)
powerpc:php71-excel-1.8.1.tgz(NetBSD 8.0)
powerpc:php72-excel-1.8.1.tgz(NetBSD 8.0)
sparc64:php54-excel-1.8.0.tgz(NetBSD 7.0)
sparc64:php55-excel-1.8.0.tgz(NetBSD 7.0)
sparc64:php56-excel-1.8.0.tgz(NetBSD 7.0)
sparc64:php56-excel-1.8.1.tgz(NetBSD 8.0)
sparc64:php70-excel-1.8.1.tgz(NetBSD 8.0)
sparc64:php71-excel-1.8.1.tgz(NetBSD 8.0)
sparc:php55-excel-1.8.0.tgz(NetBSD 5.1)
sparc:php56-excel-1.8.0.tgz(NetBSD 5.1)
sparc:php55-excel-1.8.0.tgz(NetBSD 5.1)
sparc:php56-excel-1.8.0.tgz(NetBSD 5.1)
x86_64:php56-excel-1.8.1.tgz(NetBSD 6.0)
x86_64:php70-excel-1.8.1.tgz(NetBSD 6.0)
x86_64:php71-excel-1.8.1.tgz(NetBSD 6.0)
x86_64:php72-excel-1.8.1.tgz(NetBSD 6.0)
x86_64:php56-excel-1.8.1.tgz(NetBSD 6.1)
x86_64:php70-excel-1.8.1.tgz(NetBSD 6.1)
x86_64:php71-excel-1.8.1.tgz(NetBSD 6.1)
x86_64:php72-excel-1.8.1.tgz(NetBSD 6.1)
x86_64:php56-excel-1.8.1.tgz(NetBSD 7.0)
x86_64:php70-excel-1.8.1.tgz(NetBSD 7.0)
x86_64:php71-excel-1.8.1.tgz(NetBSD 7.0)
x86_64:php72-excel-1.8.1.tgz(NetBSD 7.0)
x86_64:php56-excel-1.8.1.tgz(NetBSD 7.0)
x86_64:php70-excel-1.8.1.tgz(NetBSD 7.0)
x86_64:php71-excel-1.8.1.tgz(NetBSD 7.0)
x86_64:php56-excel-1.8.1.tgz(NetBSD 7.0)
x86_64:php70-excel-1.8.1.tgz(NetBSD 7.0)
x86_64:php71-excel-1.8.1.tgz(NetBSD 7.0)
x86_64:php72-excel-1.8.1.tgz(NetBSD 7.0)
x86_64:php56-excel-1.8.1.tgz(NetBSD 7.0)
x86_64:php70-excel-1.8.1.tgz(NetBSD 7.0)
x86_64:php71-excel-1.8.1.tgz(NetBSD 7.0)
x86_64:php72-excel-1.8.1.tgz(NetBSD 7.0)
x86_64:php56-excel-1.8.0.tgz(NetBSD 7.0.1_PATCH)
x86_64:php70-excel-1.8.0.tgz(NetBSD 7.0.1_PATCH)
x86_64:php71-excel-1.8.0.tgz(NetBSD 7.0.1_PATCH)
x86_64:php56-excel-1.8.1.tgz(NetBSD 7.1)
x86_64:php70-excel-1.8.1.tgz(NetBSD 7.1)
x86_64:php71-excel-1.8.1.tgz(NetBSD 7.1)
x86_64:php72-excel-1.8.1.tgz(NetBSD 7.1)
x86_64:php56-excel-1.8.1.tgz(NetBSD 7.1)
x86_64:php70-excel-1.8.1.tgz(NetBSD 7.1)
x86_64:php71-excel-1.8.1.tgz(NetBSD 7.1)
x86_64:php72-excel-1.8.1.tgz(NetBSD 7.1)
x86_64:php56-excel-1.8.1.tgz(NetBSD 7.1)
x86_64:php70-excel-1.8.1.tgz(NetBSD 7.1)
x86_64:php71-excel-1.8.1.tgz(NetBSD 7.1)
x86_64:php72-excel-1.8.1.tgz(NetBSD 7.1)
x86_64:php56-excel-1.8.1.tgz(NetBSD 8.0)
x86_64:php70-excel-1.8.1.tgz(NetBSD 8.0)
x86_64:php71-excel-1.8.1.tgz(NetBSD 8.0)
x86_64:php72-excel-1.8.1.tgz(NetBSD 8.0)
x86_64:php56-excel-1.8.0.tgz(NetBSD 8.99.1)
x86_64:php70-excel-1.8.0.tgz(NetBSD 8.99.1)
x86_64:php71-excel-1.8.0.tgz(NetBSD 8.99.1)
x86_64:php56-excel-1.8.1.tgz(NetBSD 8.0)
x86_64:php70-excel-1.8.1.tgz(NetBSD 8.0)
x86_64:php71-excel-1.8.1.tgz(NetBSD 8.0)
x86_64:php56-excel-1.8.1.tgz(NetBSD 8.0)
x86_64:php70-excel-1.8.1.tgz(NetBSD 8.0)
x86_64:php71-excel-1.8.1.tgz(NetBSD 8.0)
x86_64:php72-excel-1.8.1.tgz(NetBSD 8.0)
x86_64:php56-excel-1.8.1.tgz(NetBSD 8.0)
x86_64:php70-excel-1.8.1.tgz(NetBSD 8.0)
x86_64:php71-excel-1.8.1.tgz(NetBSD 8.0)
x86_64:php72-excel-1.8.1.tgz(NetBSD 8.0)
x86_64:php56-excel-1.8.0.tgz(NetBSD 8.99.1)
x86_64:php70-excel-1.8.0.tgz(NetBSD 8.99.1)
x86_64:php71-excel-1.8.0.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]