devel/boehm-gc - The NetBSD Packages Collection

Garbage collection and memory leak detection for C and C++

The Boehm-Weiser garbage collection package, for C and C++ -
garbage collection and memory leak detection libraries.

A garbage collector is something which automatically frees malloc'd
memory for you by working out what parts of memory your program
no longer has pointers to.  As a result, garbage collectors can also
inform you of memory leaks (if they find memory they can free, it means
you have lost all of your pointers to it, but you didn't free it).

This package has two libraries and some include files:
libgc.a - a garbage collection library, replaces malloc/free/new/delete/etc
    with versions that do automatic garbage collection
libleak.a - a leak detection library, which is just libgc.a compiled with
    different switches.

C programs may be linked against either of these, and should run (with
GC or leak detection) without change.  C++ programs must include a header
to use garbage collection, though leak detection should work without
such source code modifications.  See the man page and header files.

PS: garbage collection is addictive.

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/gmake devel/pkgconf

Runtime dependencies

devel/libatomic_ops

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfboehm-gc-8.0.4nb1.tgz
NetBSD 8.0earmv7hfboehm-gc-8.0.4nb1.tgz
NetBSD 8.0earmv7hfboehm-gc-8.0.4nb1.tgz
NetBSD 8.0i386boehm-gc-8.0.4nb1.tgz
NetBSD 8.0i386boehm-gc-8.0.4nb1.tgz
NetBSD 8.0i386boehm-gc-8.0.4nb1.tgz
NetBSD 8.0powerpcboehm-gc-8.0.4nb1.tgz
NetBSD 8.0powerpcboehm-gc-8.0.4nb1.tgz
NetBSD 8.0powerpcboehm-gc-8.0.4nb1.tgz
NetBSD 8.0x86_64boehm-gc-8.0.4nb1.tgz
NetBSD 8.0x86_64boehm-gc-8.0.4nb1.tgz
NetBSD 8.0x86_64boehm-gc-8.0.4nb1.tgz
NetBSD 9.0aarch64boehm-gc-8.0.4nb1.tgz
NetBSD 9.0aarch64boehm-gc-8.0.4nb1.tgz
NetBSD 9.0aarch64boehm-gc-8.0.4nb1.tgz
NetBSD 9.0alphaboehm-gc-8.0.4nb1.tgz
NetBSD 9.0alphaboehm-gc-8.0.4nb1.tgz
NetBSD 9.0alphaboehm-gc-8.0.4nb1.tgz
NetBSD 9.0earmboehm-gc-8.0.4nb1.tgz
NetBSD 9.0earmboehm-gc-8.0.4nb1.tgz
NetBSD 9.0earmboehm-gc-8.0.4nb1.tgz
NetBSD 9.0earmv6hfboehm-gc-8.0.4nb1.tgz
NetBSD 9.0earmv6hfboehm-gc-8.0.4nb1.tgz
NetBSD 9.0earmv6hfboehm-gc-8.0.4nb1.tgz
NetBSD 9.0earmv6hfboehm-gc-8.0.4nb1.tgz
NetBSD 9.0earmv7hfboehm-gc-8.0.4nb1.tgz
NetBSD 9.0earmv7hfboehm-gc-8.0.4nb1.tgz
NetBSD 9.0earmv7hfboehm-gc-8.0.4nb1.tgz
NetBSD 9.0earmv7hfboehm-gc-8.0.4nb1.tgz
NetBSD 9.0i386boehm-gc-8.0.4nb1.tgz
NetBSD 9.0i386boehm-gc-8.0.4nb1.tgz
NetBSD 9.0i386boehm-gc-8.0.4nb1.tgz
NetBSD 9.0m68kboehm-gc-8.0.4nb1.tgz
NetBSD 9.0m68kboehm-gc-8.0.4nb1.tgz
NetBSD 9.0m68kboehm-gc-8.0.4nb1.tgz
NetBSD 9.0mips64ebboehm-gc-8.0.4nb1.tgz
NetBSD 9.0mips64ebboehm-gc-8.0.4nb1.tgz
NetBSD 9.0mips64ebboehm-gc-8.0.4nb1.tgz
NetBSD 9.0powerpcboehm-gc-8.0.4nb1.tgz
NetBSD 9.0powerpcboehm-gc-8.0.4nb1.tgz
NetBSD 9.0sh3elboehm-gc-8.0.4nb1.tgz
NetBSD 9.0sh3elboehm-gc-8.0.4nb1.tgz
NetBSD 9.0sh3elboehm-gc-8.0.4nb1.tgz
NetBSD 9.0sparc64boehm-gc-8.0.4nb1.tgz
NetBSD 9.0sparc64boehm-gc-8.0.4nb1.tgz
NetBSD 9.0sparc64boehm-gc-8.0.4nb1.tgz
NetBSD 9.0sparc64boehm-gc-8.0.4nb1.tgz
NetBSD 9.0sparcboehm-gc-8.0.4nb1.tgz
NetBSD 9.0sparcboehm-gc-8.0.4nb1.tgz
NetBSD 9.0sparcboehm-gc-8.0.4nb1.tgz
NetBSD 9.0x86_64boehm-gc-8.0.4nb1.tgz
NetBSD 9.0x86_64boehm-gc-8.0.4nb1.tgz
NetBSD 9.0x86_64boehm-gc-8.0.4nb1.tgz
NetBSD 9.0x86_64boehm-gc-8.0.4nb1.tgz
NetBSD 9.0x86_64boehm-gc-8.0.4nb1.tgz
NetBSD 9.0x86_64boehm-gc-8.0.4nb1.tgz
NetBSD 9.0x86_64boehm-gc-8.0.4nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

threads
Enable threads support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.