devel/libgsf - The NetBSD Packages Collection

GNOME structured file library

libgsf provides an efficient extensible I/O abstraction for dealing
with different structured file formats.  It has support for Microsoft
OLE2 streams and Zip import.

Build dependencies

pkgtools/cwrappers devel/glib2-tools devel/libtool-base textproc/intltool devel/gmake lang/perl5 devel/pkgconf

Runtime dependencies

devel/glib2 graphics/gdk-pixbuf2 textproc/libxml2 devel/glib2 graphics/gdk-pixbuf2 textproc/libxml2

Available binary packages

aarch64:libgsf-1.14.47nb1.tgz(NetBSD 9.0)
aarch64:libgsf-1.14.47nb1.tgz(NetBSD 9.0)
aarch64:libgsf-1.14.47nb2.tgz(NetBSD 9.0)
alpha:libgsf-1.14.47nb2.tgz(NetBSD 9.0)
alpha:libgsf-1.14.47nb1.tgz(NetBSD 9.0)
alpha:libgsf-1.14.47nb1.tgz(NetBSD 9.0)
earm:libgsf-1.14.47nb1.tgz(NetBSD 9.0)
earm:libgsf-1.14.47nb2.tgz(NetBSD 9.0)
earmv6hf:libgsf-1.14.47nb2.tgz(NetBSD 9.0)
earmv6hf:libgsf-1.14.47nb1.tgz(NetBSD 9.0)
earmv6hf:libgsf-1.14.47nb1.tgz(NetBSD 9.0)
earmv6hf:libgsf-1.14.47nb2.tgz(NetBSD 9.0)
earmv7hf:libgsf-1.14.47nb2.tgz(NetBSD 8.0)
earmv7hf:libgsf-1.14.46nb1.tgz(NetBSD 8.0)
earmv7hf:libgsf-1.14.47nb1.tgz(NetBSD 8.0)
earmv7hf:libgsf-1.14.47nb1.tgz(NetBSD 8.0)
earmv7hf:libgsf-1.14.47nb2.tgz(NetBSD 9.0)
earmv7hf:libgsf-1.14.46nb1.tgz(NetBSD 9.0)
earmv7hf:libgsf-1.14.47nb1.tgz(NetBSD 9.0)
earmv7hf:libgsf-1.14.47nb1.tgz(NetBSD 9.0)
earmv7hf:libgsf-1.14.47nb2.tgz(NetBSD 9.0)
i386:libgsf-1.14.47nb1.tgz(NetBSD 8.0)
i386:libgsf-1.14.47nb1.tgz(NetBSD 8.0)
i386:libgsf-1.14.47nb2.tgz(NetBSD 8.0)
i386:libgsf-1.14.47nb1.tgz(NetBSD 9.0)
i386:libgsf-1.14.47nb1.tgz(NetBSD 9.0)
i386:libgsf-1.14.47nb2.tgz(NetBSD 9.0)
m68k:libgsf-1.14.47nb1.tgz(NetBSD 9.0)
mips64eb:libgsf-1.14.47nb1.tgz(NetBSD 9.0)
mips64eb:libgsf-1.14.47nb2.tgz(NetBSD 9.0)
mipsel:libgsf-1.14.47nb2.tgz(NetBSD 9.0)
powerpc:libgsf-1.14.47nb1.tgz(NetBSD 8.0)
powerpc:libgsf-1.14.47nb2.tgz(NetBSD 8.0)
powerpc:libgsf-1.14.47nb1.tgz(NetBSD 8.0)
powerpc:libgsf-1.14.47nb1.tgz(NetBSD 9.0)
powerpc:libgsf-1.14.47nb1.tgz(NetBSD 9.0)
sh3el:libgsf-1.14.47nb1.tgz(NetBSD 9.0)
sh3el:libgsf-1.14.47nb2.tgz(NetBSD 9.0)
sparc64:libgsf-1.14.47nb2.tgz(NetBSD 9.0)
sparc64:libgsf-1.14.47nb1.tgz(NetBSD 9.0)
sparc64:libgsf-1.14.47nb1.tgz(NetBSD 9.0)
sparc:libgsf-1.14.47nb1.tgz(NetBSD 9.0)
sparc:libgsf-1.14.47nb1.tgz(NetBSD 9.0)
sparc:libgsf-1.14.47nb2.tgz(NetBSD 9.0)
x86_64:libgsf-1.14.47nb2.tgz(NetBSD 9.0)
x86_64:libgsf-1.14.47nb2.tgz(NetBSD 9.0)
x86_64:libgsf-1.14.47nb2.tgz(NetBSD 9.0)
x86_64:libgsf-1.14.47nb1.tgz(NetBSD 9.0)
x86_64:libgsf-1.14.47nb1.tgz(NetBSD 8.0)
x86_64:libgsf-1.14.47nb1.tgz(NetBSD 8.0)
x86_64:libgsf-1.14.47nb2.tgz(NetBSD 8.0)
x86_64:libgsf-1.14.47nb1.tgz(NetBSD 9.0)
x86_64:libgsf-1.14.47nb1.tgz(NetBSD 9.0)
x86_64:libgsf-1.14.47nb2.tgz(NetBSD 9.0)
x86_64:libgsf-1.14.47nb2.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]