emulators/dolphin-emu - The NetBSD Packages Collection

Nintendo GameCube and Wii emulator

Dolphin is an emulator for two recent Nintendo video game consoles:
the GameCube and the Wii. It allows PC gamers to enjoy games for
these two consoles in full HD (1080p) with several enhancements:
compatibility with all PC controllers, turbo speed, networked
multiplayer, and even more!

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/glib2-tools devel/cmake devel/pkgconf

Runtime dependencies

audio/libao-sun audio/alsa-lib audio/libao devel/libusb1 graphics/hicolor-icon-theme graphics/MesaLib x11/liboldXrandr x11/liboldXrandr multimedia/ffmpeg4 net/miniupnpc security/mbedtls www/curl archivers/lzo devel/SDL2 graphics/png x11/wxGTK30 audio/libao graphics/hicolor-icon-theme graphics/MesaLib x11/liboldXrandr multimedia/ffmpeg4 security/mbedtls www/curl devel/SDL2 graphics/png x11/wxGTK30

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfdolphin-emu-5.0nb18.tgz
NetBSD 8.0earmv7hfdolphin-emu-5.0nb20.tgz
NetBSD 8.0i386dolphin-emu-5.0nb18.tgz
NetBSD 8.0i386dolphin-emu-5.0nb18.tgz
NetBSD 8.0i386dolphin-emu-5.0nb20.tgz
NetBSD 8.0x86_64dolphin-emu-5.0nb20.tgz
NetBSD 8.0x86_64dolphin-emu-5.0nb18.tgz
NetBSD 8.0x86_64dolphin-emu-5.0nb18.tgz
NetBSD 9.0aarch64dolphin-emu-5.0nb20.tgz
NetBSD 9.0aarch64dolphin-emu-5.0nb18.tgz
NetBSD 9.0aarch64dolphin-emu-5.0nb18.tgz
NetBSD 9.0alphadolphin-emu-5.0nb20.tgz
NetBSD 9.0alphadolphin-emu-5.0nb18.tgz
NetBSD 9.0earmv6hfdolphin-emu-5.0nb20.tgz
NetBSD 9.0earmv6hfdolphin-emu-5.0nb18.tgz
NetBSD 9.0earmv6hfdolphin-emu-5.0nb18.tgz
NetBSD 9.0earmv6hfdolphin-emu-5.0nb18.tgz
NetBSD 9.0earmv7hfdolphin-emu-5.0nb20.tgz
NetBSD 9.0earmv7hfdolphin-emu-5.0nb18.tgz
NetBSD 9.0earmv7hfdolphin-emu-5.0nb18.tgz
NetBSD 9.0i386dolphin-emu-5.0nb18.tgz
NetBSD 9.0i386dolphin-emu-5.0nb18.tgz
NetBSD 9.0i386dolphin-emu-5.0nb20.tgz
NetBSD 9.0x86_64dolphin-emu-5.0nb18.tgz
NetBSD 9.0x86_64dolphin-emu-5.0nb19.tgz
NetBSD 9.0x86_64dolphin-emu-5.0nb19.tgz
NetBSD 9.0x86_64dolphin-emu-5.0nb20.tgz
NetBSD 9.0x86_64dolphin-emu-5.0nb18.tgz
NetBSD 9.0x86_64dolphin-emu-5.0nb18.tgz
NetBSD 9.0x86_64dolphin-emu-5.0nb20.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

alsa
Enable ALSA support.
libao
Enable the platform-independent 'ao' audio library.
llvm
Enable run time generation with Low Level Virtual Machine.
openal
Enable OpenAL support.
portaudio
Enable PortAudio audio library support.
pulseaudio
Enable support for the PulseAudio sound server.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.