emulators/gpsim-ptyusart - The NetBSD Packages Collection

Pseudo-tty module for gpsim

This is a serial module for gpsim, connecting the virtual Rx/Tx lines
to a pseudo-tty (pty). You can then use your usual serial tools (cu, tip,
minicom, etc ...) on this pty as you would do on a real serial port on
your Unix workstation.
Included is an example loopback program for a pic18f (that is, it will
just echo back what you send it). tstloopback.c can be used along with
cu or tip (or possibly minicom) to copy an arbitrary file though the
serial port and the pic, which allows to check for data corruption
(if you notice that 0x11 and 0x13 characters get lost, check for
the XON/XOFF status of your pty :)

This module has been developed for gpsim from CVS 20040816:
http://www-asim.lip6.fr/~bouyer/pic/gpsim-20040826.tar.gz

For now this has only been tested on NetBSD. It should work without
much troubles on others BSDs. More work is needed for other unix-like
operating systems (probably require a usart_external.cc per pty style).

Please address comments, bug-fixes or updates to Manuel.Bouyer@lip6.fr

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/glib2-tools devel/libtool-base devel/pkgconf

Runtime dependencies

emulators/gpsim-devel emulators/gpsim-devel

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfgpsim-ptyusart-0.3.2nb35.tgz
NetBSD 8.0earmv7hfgpsim-ptyusart-0.3.2nb35.tgz
NetBSD 8.0i386gpsim-ptyusart-0.3.2nb35.tgz
NetBSD 8.0i386gpsim-ptyusart-0.3.2nb35.tgz
NetBSD 8.0i386gpsim-ptyusart-0.3.2nb35.tgz
NetBSD 8.0powerpcgpsim-ptyusart-0.3.2nb35.tgz
NetBSD 8.0powerpcgpsim-ptyusart-0.3.2nb35.tgz
NetBSD 8.0powerpcgpsim-ptyusart-0.3.2nb35.tgz
NetBSD 8.0x86_64gpsim-ptyusart-0.3.2nb35.tgz
NetBSD 8.0x86_64gpsim-ptyusart-0.3.2nb35.tgz
NetBSD 8.0x86_64gpsim-ptyusart-0.3.2nb35.tgz
NetBSD 9.0aarch64gpsim-ptyusart-0.3.2nb35.tgz
NetBSD 9.0aarch64gpsim-ptyusart-0.3.2nb35.tgz
NetBSD 9.0aarch64gpsim-ptyusart-0.3.2nb35.tgz
NetBSD 9.0alphagpsim-ptyusart-0.3.2nb35.tgz
NetBSD 9.0alphagpsim-ptyusart-0.3.2nb35.tgz
NetBSD 9.0alphagpsim-ptyusart-0.3.2nb35.tgz
NetBSD 9.0earmv6hfgpsim-ptyusart-0.3.2nb35.tgz
NetBSD 9.0earmv6hfgpsim-ptyusart-0.3.2nb35.tgz
NetBSD 9.0earmv6hfgpsim-ptyusart-0.3.2nb35.tgz
NetBSD 9.0earmv6hfgpsim-ptyusart-0.3.2nb35.tgz
NetBSD 9.0earmv7hfgpsim-ptyusart-0.3.2nb35.tgz
NetBSD 9.0earmv7hfgpsim-ptyusart-0.3.2nb35.tgz
NetBSD 9.0earmv7hfgpsim-ptyusart-0.3.2nb35.tgz
NetBSD 9.0earmv7hfgpsim-ptyusart-0.3.2nb35.tgz
NetBSD 9.0i386gpsim-ptyusart-0.3.2nb35.tgz
NetBSD 9.0i386gpsim-ptyusart-0.3.2nb35.tgz
NetBSD 9.0i386gpsim-ptyusart-0.3.2nb35.tgz
NetBSD 9.0mips64ebgpsim-ptyusart-0.3.2nb35.tgz
NetBSD 9.0mips64ebgpsim-ptyusart-0.3.2nb35.tgz
NetBSD 9.0mips64ebgpsim-ptyusart-0.3.2nb35.tgz
NetBSD 9.0powerpcgpsim-ptyusart-0.3.2nb35.tgz
NetBSD 9.0powerpcgpsim-ptyusart-0.3.2nb35.tgz
NetBSD 9.0sparc64gpsim-ptyusart-0.3.2nb35.tgz
NetBSD 9.0sparc64gpsim-ptyusart-0.3.2nb35.tgz
NetBSD 9.0sparc64gpsim-ptyusart-0.3.2nb35.tgz
NetBSD 9.0sparcgpsim-ptyusart-0.3.2nb35.tgz
NetBSD 9.0sparcgpsim-ptyusart-0.3.2nb35.tgz
NetBSD 9.0x86_64gpsim-ptyusart-0.3.2nb35.tgz
NetBSD 9.0x86_64gpsim-ptyusart-0.3.2nb35.tgz
NetBSD 9.0x86_64gpsim-ptyusart-0.3.2nb35.tgz
NetBSD 9.0x86_64gpsim-ptyusart-0.3.2nb35.tgz
NetBSD 9.0x86_64gpsim-ptyusart-0.3.2nb35.tgz
NetBSD 9.0x86_64gpsim-ptyusart-0.3.2nb35.tgz
NetBSD 9.0x86_64gpsim-ptyusart-0.3.2nb35.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.