Daemon Power

The NetBSD Packages Collection: misc/ruby-ohai

Brief description of the package:
Ohai profiles your system and emits JSON

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://github.com/opscode/ohai.

Please note that this package has a apache-2.0 license.

The package is located in the "misc/ruby-ohai" directory. The current source version of the package is "ruby26-ohai-16.0.20". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for misc/ruby-ohai :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: ruby26-systemu>=2.6.4<2.7 ruby26-base>=2.6.6 openssl>=1.1.1 cwrappers>=20150314 libyaml>=0.1.1 openssl>=1.1.1dnb2 libyaml>=0.1.4 ruby26-ffi-yajl>=2.2<3 ruby26-libyajl2>=1.2 yajl>=1.0.9 ruby26-mixlib-cli>=1.7.0 ruby26-mixlib-config>=2.0 ruby26-tomlrb>=0 ruby26-mixlib-log>=2.0.1 ruby26-mixlib-shellout>=2.0 ruby26-plist>=3.1<4 ruby26-ipaddress>=0.8.0 ruby26-wmi-lite>=1.0<2 ruby26-ffi>=1.9<2 libffi>=1.20 libffi>=3.3nb1 ruby26-chef-config>=12.8 ruby26-chef-utils>=16.0.287<16.1 ruby26-mixlib-config>=2.2.12 ruby26-fuzzyurl>=0 ruby26-addressable>=0 ruby26-public_suffix>=2.0.2 ruby26-tomlrb>=1.2<2 .

This package requires the following package(s) to run: ruby26-systemu>=2.6.4<2.7 ruby26-base>=2.6.6 openssl>=1.1.1 libyaml>=0.1.1 openssl>=1.1.1dnb2 libyaml>=0.1.4 ruby26-ffi-yajl>=2.2<3 ruby26-libyajl2>=1.2 yajl>=1.0.9 ruby26-mixlib-cli>=1.7.0 ruby26-mixlib-config>=2.0 ruby26-tomlrb>=0 ruby26-mixlib-log>=2.0.1 ruby26-mixlib-shellout>=2.0 ruby26-plist>=3.1<4 ruby26-ipaddress>=0.8.0 ruby26-wmi-lite>=1.0<2 ruby26-ffi>=1.9<2 libffi>=1.20 libffi>=3.3nb1 ruby26-chef-config>=12.8 ruby26-chef-utils>=16.0.287<16.1 ruby26-mixlib-config>=2.2.12 ruby26-fuzzyurl>=0 ruby26-addressable>=0 ruby26-public_suffix>=2.0.2 ruby26-tomlrb>=1.2<2 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
alpha:ruby24-ohai-14.8.10.tgz(NetBSD 8.0)
alpha:ruby25-ohai-14.8.10.tgz(NetBSD 8.0)
alpha:ruby26-ohai-14.8.10.tgz(NetBSD 8.0)
alpha:ruby24-ohai-14.8.10.tgz(NetBSD 9.0)
alpha:ruby25-ohai-14.8.10.tgz(NetBSD 9.0)
alpha:ruby26-ohai-14.8.10.tgz(NetBSD 9.0)
earm:ruby200-ohai-8.8.1.tgz(NetBSD 7.0)
earm:ruby21-ohai-8.8.1.tgz(NetBSD 7.0)
earm:ruby22-ohai-8.8.1.tgz(NetBSD 7.0)
earm:ruby25-ohai-14.8.10.tgz(NetBSD 8.0)
earm:ruby25-ohai-14.8.10.tgz(NetBSD 8.0)
earmv6hf:ruby24-ohai-14.8.10.tgz(NetBSD 8.0)
earmv6hf:ruby25-ohai-14.8.10.tgz(NetBSD 8.0)
earmv6hf:ruby26-ohai-14.8.10.tgz(NetBSD 8.0)
earmv6hf:ruby24-ohai-14.8.10.tgz(NetBSD 9.0)
earmv6hf:ruby25-ohai-14.8.10.tgz(NetBSD 9.0)
earmv6hf:ruby26-ohai-14.8.10.tgz(NetBSD 9.0)
earmv7hf:ruby25-ohai-15.7.4.tgz(NetBSD 8.0)
earmv7hf:ruby26-ohai-15.7.4.tgz(NetBSD 8.0)
earmv7hf:ruby27-ohai-15.7.4.tgz(NetBSD 8.0)
earmv7hf:ruby24-ohai-14.8.10.tgz(NetBSD 8.0)
earmv7hf:ruby25-ohai-14.8.10.tgz(NetBSD 8.0)
earmv7hf:ruby26-ohai-14.8.10.tgz(NetBSD 8.0)
earmv7hf:ruby24-ohai-14.8.10.tgz(NetBSD 9.0)
earmv7hf:ruby25-ohai-14.8.10.tgz(NetBSD 9.0)
earmv7hf:ruby26-ohai-14.8.10.tgz(NetBSD 9.0)
i386:ruby25-ohai-15.7.4.tgz(NetBSD 9.0)
i386:ruby26-ohai-15.7.4.tgz(NetBSD 9.0)
i386:ruby27-ohai-15.7.4.tgz(NetBSD 9.0)
i386:ruby24-ohai-14.8.10.tgz(NetBSD 7.0)
i386:ruby25-ohai-14.8.10.tgz(NetBSD 7.0)
i386:ruby24-ohai-14.8.10.tgz(NetBSD 7.0)
i386:ruby25-ohai-14.8.10.tgz(NetBSD 7.0)
i386:ruby24-ohai-14.8.10.tgz(NetBSD 7.1)
i386:ruby25-ohai-14.8.10.tgz(NetBSD 7.1)
i386:ruby24-ohai-14.8.10.tgz(NetBSD 7.1)
i386:ruby25-ohai-14.8.10.tgz(NetBSD 7.1)
i386:ruby25-ohai-15.7.4.tgz(NetBSD 7.1)
i386:ruby24-ohai-14.8.10.tgz(NetBSD 8.0)
i386:ruby25-ohai-14.8.10.tgz(NetBSD 8.0)
i386:ruby26-ohai-14.8.10.tgz(NetBSD 8.0)
i386:ruby24-ohai-14.8.10.tgz(NetBSD 8.0)
i386:ruby25-ohai-14.8.10.tgz(NetBSD 8.0)
i386:ruby26-ohai-14.8.10.tgz(NetBSD 8.0)
i386:ruby25-ohai-15.7.4.tgz(NetBSD 8.0)
i386:ruby26-ohai-15.7.4.tgz(NetBSD 8.0)
i386:ruby27-ohai-15.7.4.tgz(NetBSD 8.0)
i386:ruby25-ohai-15.7.4.tgz(NetBSD 9.0)
i386:ruby26-ohai-15.7.4.tgz(NetBSD 9.0)
i386:ruby27-ohai-15.7.4.tgz(NetBSD 9.0)
i386:ruby24-ohai-14.8.10.tgz(NetBSD 9.0)
i386:ruby25-ohai-14.8.10.tgz(NetBSD 9.0)
i386:ruby26-ohai-14.8.10.tgz(NetBSD 9.0)
mips64eb:ruby24-ohai-14.8.10.tgz(NetBSD 9.0)
mips64eb:ruby25-ohai-14.8.10.tgz(NetBSD 9.0)
mips64eb:ruby26-ohai-14.8.10.tgz(NetBSD 9.0)
powerpc:ruby24-ohai-14.5.4.tgz(NetBSD 7.1)
powerpc:ruby25-ohai-14.5.4.tgz(NetBSD 7.1)
powerpc:ruby24-ohai-14.8.10.tgz(NetBSD 8.0)
powerpc:ruby25-ohai-14.8.10.tgz(NetBSD 8.0)
powerpc:ruby26-ohai-14.8.10.tgz(NetBSD 8.0)
powerpc:ruby24-ohai-14.8.10.tgz(NetBSD 9.0)
powerpc:ruby25-ohai-14.8.10.tgz(NetBSD 9.0)
powerpc:ruby26-ohai-14.8.10.tgz(NetBSD 9.0)
sparc64:ruby23-ohai-13.4.0.tgz(NetBSD 7.1)
sparc64:ruby24-ohai-13.4.0.tgz(NetBSD 7.1)
sparc64:ruby25-ohai-13.4.0.tgz(NetBSD 7.1)
sparc64:ruby24-ohai-14.8.10.tgz(NetBSD 8.0)
sparc64:ruby25-ohai-14.8.10.tgz(NetBSD 8.0)
sparc64:ruby26-ohai-14.8.10.tgz(NetBSD 8.0)
sparc64:ruby24-ohai-14.8.10.tgz(NetBSD 9.0)
sparc64:ruby25-ohai-14.8.10.tgz(NetBSD 9.0)
sparc64:ruby26-ohai-14.8.10.tgz(NetBSD 9.0)
sparc:ruby24-ohai-14.8.10.tgz(NetBSD 8.0)
sparc:ruby25-ohai-14.8.10.tgz(NetBSD 8.0)
x86_64:ruby25-ohai-15.7.4.tgz(NetBSD 9.0)
x86_64:ruby26-ohai-15.7.4.tgz(NetBSD 9.0)
x86_64:ruby27-ohai-15.7.4.tgz(NetBSD 9.0)
x86_64:ruby25-ohai-15.7.4.tgz(NetBSD 9.0)
x86_64:ruby26-ohai-15.7.4.tgz(NetBSD 9.0)
x86_64:ruby27-ohai-15.7.4.tgz(NetBSD 9.0)
x86_64:ruby24-ohai-14.8.10.tgz(NetBSD 7.0)
x86_64:ruby25-ohai-14.8.10.tgz(NetBSD 7.0)
x86_64:ruby24-ohai-14.8.10.tgz(NetBSD 7.0)
x86_64:ruby25-ohai-14.8.10.tgz(NetBSD 7.0)
x86_64:ruby24-ohai-14.8.10.tgz(NetBSD 7.1)
x86_64:ruby25-ohai-14.8.10.tgz(NetBSD 7.1)
x86_64:ruby24-ohai-14.8.10.tgz(NetBSD 7.1)
x86_64:ruby25-ohai-14.8.10.tgz(NetBSD 7.1)
x86_64:ruby25-ohai-15.7.4.tgz(NetBSD 7.1)
x86_64:ruby25-ohai-15.7.4.tgz(NetBSD 8.0)
x86_64:ruby26-ohai-15.7.4.tgz(NetBSD 8.0)
x86_64:ruby27-ohai-15.7.4.tgz(NetBSD 8.0)
x86_64:ruby24-ohai-14.8.10.tgz(NetBSD 8.0)
x86_64:ruby25-ohai-14.8.10.tgz(NetBSD 8.0)
x86_64:ruby26-ohai-14.8.10.tgz(NetBSD 8.0)
x86_64:ruby24-ohai-14.8.10.tgz(NetBSD 8.0)
x86_64:ruby25-ohai-14.8.10.tgz(NetBSD 8.0)
x86_64:ruby26-ohai-14.8.10.tgz(NetBSD 8.0)
x86_64:ruby25-ohai-15.7.4.tgz(NetBSD 9.0)
x86_64:ruby26-ohai-15.7.4.tgz(NetBSD 9.0)
x86_64:ruby27-ohai-15.7.4.tgz(NetBSD 9.0)
x86_64:ruby24-ohai-14.8.10.tgz(NetBSD 9.0)
x86_64:ruby25-ohai-14.8.10.tgz(NetBSD 9.0)
x86_64:ruby26-ohai-14.8.10.tgz(NetBSD 9.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]