time/ocaml-mtime - The NetBSD Packages Collection

Monotonic wall-clock time for OCaml

Mtime has platform independent support for monotonic wall-clock time in pure
OCaml. The additional Mtime_clock library provide access to a system monotonic
clock.

Build dependencies

misc/ocaml-opaline devel/ocamlbuild pkgtools/cwrappers misc/ocaml-opaline devel/ocamlbuild

Runtime dependencies

misc/ocaml-topkg devel/ocaml-findlib lang/ocaml misc/ocaml-topkg devel/ocaml-findlib

Binary packages

OSArchitectureVersion
NetBSD 8.0i386ocaml-mtime-1.1.0.tgz
NetBSD 8.0i386ocaml-mtime-1.1.0.tgz
NetBSD 8.0i386ocaml-mtime-1.1.0nb1.tgz
NetBSD 8.0powerpcocaml-mtime-1.1.0.tgz
NetBSD 8.0powerpcocaml-mtime-1.1.0.tgz
NetBSD 8.0x86_64ocaml-mtime-1.1.0nb1.tgz
NetBSD 8.0x86_64ocaml-mtime-1.1.0.tgz
NetBSD 8.0x86_64ocaml-mtime-1.1.0.tgz
NetBSD 9.0aarch64ocaml-mtime-1.1.0nb1.tgz
NetBSD 9.0aarch64ocaml-mtime-1.1.0.tgz
NetBSD 9.0aarch64ocaml-mtime-1.1.0.tgz
NetBSD 9.0earmv6hfocaml-mtime-1.1.0nb1.tgz
NetBSD 9.0earmv6hfocaml-mtime-1.1.0.tgz
NetBSD 9.0earmv6hfocaml-mtime-1.1.0.tgz
NetBSD 9.0earmv7hfocaml-mtime-1.1.0nb1.tgz
NetBSD 9.0earmv7hfocaml-mtime-1.1.0.tgz
NetBSD 9.0earmv7hfocaml-mtime-1.1.0.tgz
NetBSD 9.0earmv7hfocaml-mtime-1.1.0nb1.tgz
NetBSD 9.0i386ocaml-mtime-1.1.0.tgz
NetBSD 9.0i386ocaml-mtime-1.1.0.tgz
NetBSD 9.0i386ocaml-mtime-1.1.0nb1.tgz
NetBSD 9.0powerpcocaml-mtime-1.1.0.tgz
NetBSD 9.0powerpcocaml-mtime-1.1.0nb1.tgz
NetBSD 9.0x86_64ocaml-mtime-1.1.0.tgz
NetBSD 9.0x86_64ocaml-mtime-1.1.0.tgz
NetBSD 9.0x86_64ocaml-mtime-1.1.0.tgz
NetBSD 9.0x86_64ocaml-mtime-1.1.0nb1.tgz
NetBSD 9.0x86_64ocaml-mtime-1.1.0.tgz
NetBSD 9.0x86_64ocaml-mtime-1.1.0.tgz
NetBSD 9.0x86_64ocaml-mtime-1.1.0nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

js_of_ocaml

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.