Daemon Power

The NetBSD Packages Collection: databases/libgda-mysql

Brief description of the package:
GNU database access library - mysql provider

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://www.gnome-db.org/.

Please note that this package has a gnu-gpl-v2 license.

The package is located in the "databases/libgda-mysql" directory. The current source version of the package is "libgda-mysql-5.2.9nb3". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for databases/libgda-mysql :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: libgda>=2.99.2 readline>=2.2 cwrappers>=20150314 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 glib2>=2.4.0 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.3nb1 meson-[0-9]* ninja-build>=1.7 python37>=3.7 libuuid>=2.18 readline>=6.0 python37>=3.7.0 re2c>=0.11.3 py37-setuptools>=0.8 py37-expat-[0-9]* python37>=3.7.8 libxml2>=2.9.10nb2 glib2>=2.64.0nb1 mysql-client>=5.7.12<5.8 perl>=5.0 lz4>=1.7.3<100 boost-libs-1.73.* icu>=3.4 icu>=67.1 boost-jam-1.73.* editline>=3.0.20130712nb1 libevent>=0.6 lz4>=1.7.3 boost-libs>=1.73.0 libevent>=2.1.11nb1 boost-headers-1.73.* libgda>=5.2.9nb3 mysql-client>=5.7.28nb2 .

This package requires the following package(s) to run: libgda>=2.99.2 readline>=2.2 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 glib2>=2.4.0 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.3nb1 readline>=6.0 libxml2>=2.9.10nb2 glib2>=2.64.0nb1 mysql-client>=5.7.12<5.8 perl>=5.0 lz4>=1.7.3<100 boost-libs-1.73.* icu>=3.4 icu>=67.1 editline>=3.0.20130712nb1 libevent>=0.6 lz4>=1.7.3 boost-libs>=1.73.0 libevent>=2.1.11nb1 libgda>=5.2.9nb3 mysql-client>=5.7.28nb2 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
alpha:libgda-mysql-5.2.9.tgz(NetBSD 8.0)
earm:libgda-mysql-5.2.2nb1.tgz(NetBSD 7.0)
earmv6hf:libgda-mysql-5.2.9.tgz(NetBSD 8.0)
earmv6hf:libgda-mysql-5.2.9.tgz(NetBSD 9.0)
earmv7hf:libgda-mysql-5.2.9nb2.tgz(NetBSD 8.0)
earmv7hf:libgda-mysql-5.2.9.tgz(NetBSD 8.0)
earmv7hf:libgda-mysql-5.2.9nb3.tgz(NetBSD 8.0)
earmv7hf:libgda-mysql-5.2.9nb2.tgz(NetBSD 9.0)
earmv7hf:libgda-mysql-5.2.9.tgz(NetBSD 9.0)
i386:libgda-mysql-5.2.9nb2.tgz(NetBSD 9.0)
i386:libgda-mysql-5.2.9.tgz(NetBSD 7.0)
i386:libgda-mysql-5.2.9.tgz(NetBSD 7.0)
i386:libgda-mysql-5.2.9.tgz(NetBSD 7.1)
i386:libgda-mysql-5.2.9.tgz(NetBSD 7.1)
i386:libgda-mysql-5.2.9nb2.tgz(NetBSD 7.1)
i386:libgda-mysql-5.2.9nb3.tgz(NetBSD 8.0)
i386:libgda-mysql-5.2.9.tgz(NetBSD 8.0)
i386:libgda-mysql-5.2.9.tgz(NetBSD 8.0)
i386:libgda-mysql-5.2.9nb2.tgz(NetBSD 8.0)
i386:libgda-mysql-5.2.9nb3.tgz(NetBSD 9.0)
i386:libgda-mysql-5.2.9.tgz(NetBSD 9.0)
i386:libgda-mysql-5.2.9nb2.tgz(NetBSD 9.0)
i386:libgda-mysql-3.0.1nb3.tgz(QNX 6.5.0)
powerpc:libgda-mysql-5.2.2nb2.tgz(NetBSD 7.1)
sparc64:libgda-mysql-5.2.9.tgz(NetBSD 8.0)
sparc64:libgda-mysql-5.2.9.tgz(NetBSD 9.0)
x86_64:libgda-mysql-5.2.9nb2.tgz(NetBSD 9.0)
x86_64:libgda-mysql-5.2.9nb2.tgz(NetBSD 9.0)
x86_64:libgda-mysql-5.2.9.tgz(NetBSD 7.0)
x86_64:libgda-mysql-5.2.9.tgz(NetBSD 7.0)
x86_64:libgda-mysql-5.2.9.tgz(NetBSD 7.1)
x86_64:libgda-mysql-5.2.9.tgz(NetBSD 7.1)
x86_64:libgda-mysql-5.2.9nb2.tgz(NetBSD 7.1)
x86_64:libgda-mysql-5.2.9nb2.tgz(NetBSD 8.0)
x86_64:libgda-mysql-5.2.9.tgz(NetBSD 8.0)
x86_64:libgda-mysql-5.2.9.tgz(NetBSD 8.0)
x86_64:libgda-mysql-5.2.9nb3.tgz(NetBSD 8.0)
x86_64:libgda-mysql-5.2.9nb3.tgz(NetBSD 9.0)
x86_64:libgda-mysql-5.2.9.tgz(NetBSD 9.0)
x86_64:libgda-mysql-5.2.9nb2.tgz(NetBSD 9.0)
x86_64:libgda-mysql-5.2.9nb3.tgz(NetBSD 9.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]