Daemon Power

The NetBSD Packages Collection: games/easyrpg-player

Brief description of the package:
RPG Maker 2000/2003 and EasyRPG games interpreter

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://easyrpg.org/.

Please note that this package has a gnu-gpl-v3 license.

The package is located in the "games/easyrpg-player" directory. The current source version of the package is "easyrpg-player-0.6.2.2". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for games/easyrpg-player :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: freetype2>=2.8.1 cwrappers>=20150314 freetype2>=2.1.3 harfbuzz>=2.1.1 glib2>=2.4.0 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.3nb1 meson-[0-9]* ninja-build>=1.7 python37>=3.7 libuuid>=2.18 readline>=2.2 readline>=6.0 python37>=3.7.0 re2c>=0.11.3 py37-setuptools-[0-9]* py37-expat-[0-9]* python37>=3.7.9 icu>=3.4 graphite2>=1.2 glib2>=2.64.0nb1 icu>=67.1 gtk-doc>=1.18 docbook-xml>=4.4nb1 xmlcatmgr>=2.0beta1 docbook-xsl>=1.68.1 docbook-xml>=4.2 perl>=5.0 py37-anytree-[0-9]* py37-six>=1.9.0 py37-lxml-[0-9]* libxml2>=2.9.2 libxml2>=2.6.2 libxslt>=1.1.27 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 libgcrypt>=1.6.0 libxml2>=2.9.10nb2 docbook-xml-[0-9]* docbook-xsl-[0-9]* libxslt>=1.1.8 libxslt>=1.1.34nb2 py37-pygments-[0-9]* pkgconf-[0-9]* itstool-[0-9]* py37-libxml2-[0-9]* libxml2>=2.9.10 py37-expat>=0 gnome-doc-utils>=0.8.0 py27-libxml2>=2.6.16 py27-libxslt>=1.1.12 py27-expat-[0-9]* py27-libxml2>=2.6.8 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 py27-libxml2>=2.6.27 libxslt>=1.1.34 python27>=2.7.1nb2 docbook-xml>=4.5 getopt-[0-9]* bash-[0-9]* libxml2>=2.6.12 gobject-introspection>=0.6.14nb1 py37-cElementTree-[0-9]* glib2>=2.58.0 libffi>=3.0.0 gtk-doc>=1.32nb2 gobject-introspection>=1.62.0nb1 mpg123>=1.0.0 libvorbis>=1.0.1 libogg>=1.1 libogg>=1.1.2nb1 libopus>=1.1 libsndfile>=1.0.0 flac>=1.1.0nb1 libogg>=1.1.3 flac>=1.1.3nb1 libvorbis>=1.1.0nb1 speexdsp>=1.2rc3 speex>=1.2rc2 speex>=1.2rc1 libxmp>=4.1.5 SDL2_mixer>=2.0.0 libmodplug>=0.7 opusfile>=0.5 SDL2>=2.0 MesaLib>=3.4.2 libelf>=0.8.5 libLLVM>=7.0.1nb2 libLLVM>=9.0.0 libvdpau>=0.3 x11-links>=1.32 osabi-NetBSD-9.0_STABLE xorgproto>=2016.1 libXdamage>=1.0.3 Xfixes>=2.0.0 fixesproto>=3.0.0<5 Xfixes>=2.0.1nb2 Xrandr>=0.99 libXrender>=0.9.2 Xrandr>=1.0.1 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 xcb-proto>=1.14 xcb-proto>=1.4 libxshmfence>=1.2 xorg-util-macros>=1.17 libdrm>=2.4.99 libdrm>=2.4.100 libdrm>=2.4.15 libva>=2.3.0 Xrandr>=1.0.2nb3 libXScrnSaver>=1.1.2 xcursor>=1.0 xcursor>=1.1.1 libsamplerate>=0.0.13nb1 libsndfile>=1.0.2 fftw>=3.0 libsndfile>=1.0.29nb1 fftw>=3.1nb1 MesaLib>=20.0.1nb1 xcursor>=1.1.2nb1 libsamplerate>=0.1.9nb1 libmodplug>=0.8.8.1 opusfile>=0.11nb1 SDL2>=2.0.12nb5 liblcf>=0.5.4 shared-mime-info>=0.15 shared-mime-info>=1.0nb1 png>=1.2.4 pixman>=0.25.2 harfbuzz>=2.6.4nb2 SDL2_mixer>=2.0.4nb3 liblcf>=0.6.2nb1 png>=1.6.0nb1 .

This package requires the following package(s) to run: freetype2>=2.8.1 freetype2>=2.1.3 harfbuzz>=2.1.1 glib2>=2.4.0 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.3nb1 icu>=3.4 graphite2>=1.2 glib2>=2.64.0nb1 icu>=67.1 mpg123>=1.0.0 libvorbis>=1.0.1 libogg>=1.1 libogg>=1.1.2nb1 libopus>=1.1 libsndfile>=1.0.0 flac>=1.1.0nb1 libogg>=1.1.3 flac>=1.1.3nb1 libvorbis>=1.1.0nb1 speexdsp>=1.2rc3 speex>=1.2rc2 speex>=1.2rc1 libxmp>=4.1.5 SDL2_mixer>=2.0.0 libmodplug>=0.7 opusfile>=0.5 SDL2>=2.0 MesaLib>=3.4.2 libelf>=0.8.5 libLLVM>=7.0.1nb2 libLLVM>=9.0.0 libvdpau>=0.3 python37>=3.7 libuuid>=2.18 python37>=3.7.0 libXdamage>=1.0.3 Xfixes>=2.0.0 Xfixes>=2.0.1nb2 Xrandr>=0.99 libXrender>=0.9.2 Xrandr>=1.0.1 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 libxshmfence>=1.2 libdrm>=2.4.99 libdrm>=2.4.100 libdrm>=2.4.15 libva>=2.3.0 Xrandr>=1.0.2nb3 libXScrnSaver>=1.1.2 xcursor>=1.0 xcursor>=1.1.1 libsamplerate>=0.0.13nb1 libsndfile>=1.0.2 fftw>=3.0 libsndfile>=1.0.29nb1 fftw>=3.1nb1 MesaLib>=20.0.1nb1 xcursor>=1.1.2nb1 libsamplerate>=0.1.9nb1 libmodplug>=0.8.8.1 opusfile>=0.11nb1 SDL2>=2.0.12nb5 liblcf>=0.5.4 shared-mime-info>=0.15 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.9.10nb2 shared-mime-info>=1.0nb1 png>=1.2.4 pixman>=0.25.2 harfbuzz>=2.6.4nb2 SDL2_mixer>=2.0.4nb3 liblcf>=0.6.2nb1 png>=1.6.0nb1 .

This package supports the following build-time options:

freetype
Enable freetype support.

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
aarch64:easyrpg-player-0.6.2.1nb2.tgz(NetBSD 9.0)
aarch64:easyrpg-player-0.6.1.tgz(NetBSD 9.0)
aarch64:easyrpg-player-0.6.1nb2.tgz(NetBSD 9.0)
aarch64:easyrpg-player-0.6.2.1nb1.tgz(NetBSD 9.0)
aarch64:easyrpg-player-0.6.2.1nb2.tgz(NetBSD 9.0)
alpha:easyrpg-player-0.6.1.tgz(NetBSD 8.0)
alpha:easyrpg-player-0.6.1.tgz(NetBSD 9.0)
earmv6hf:easyrpg-player-0.6.2.1nb1.tgz(NetBSD 9.0)
earmv7hf:easyrpg-player-0.6.2.1nb1.tgz(NetBSD 9.0)
earmv7hf:easyrpg-player-0.6.2.1nb2.tgz(NetBSD 9.0)
i386:easyrpg-player-0.6.1nb2.tgz(NetBSD 9.0)
i386:easyrpg-player-0.6.1.tgz(NetBSD 8.0)
i386:easyrpg-player-0.6.1.tgz(NetBSD 8.0)
i386:easyrpg-player-0.6.1nb2.tgz(NetBSD 8.0)
i386:easyrpg-player-0.6.2.1nb2.tgz(NetBSD 9.0)
i386:easyrpg-player-0.6.1.tgz(NetBSD 9.0)
i386:easyrpg-player-0.6.1nb2.tgz(NetBSD 9.0)
i386:easyrpg-player-0.6.2.1nb1.tgz(NetBSD 9.0)
m68k:easyrpg-player-0.6.0.tgz(NetBSD 8.0)
powerpc:easyrpg-player-0.6.1.tgz(NetBSD 8.0)
powerpc:easyrpg-player-0.6.2.1nb1.tgz(NetBSD 9.0)
powerpc:easyrpg-player-0.6.1.tgz(NetBSD 9.0)
sparc64:easyrpg-player-0.6.1.tgz(NetBSD 8.0)
x86_64:easyrpg-player-0.6.2.1nb1.tgz(NetBSD 9.0)
x86_64:easyrpg-player-0.6.2.1nb1.tgz(NetBSD 9.0)
x86_64:easyrpg-player-0.6.1nb2.tgz(NetBSD 8.0)
x86_64:easyrpg-player-0.6.1.tgz(NetBSD 8.0)
x86_64:easyrpg-player-0.6.1.tgz(NetBSD 8.0)
x86_64:easyrpg-player-0.6.2.1nb2.tgz(NetBSD 9.0)
x86_64:easyrpg-player-0.6.1.tgz(NetBSD 9.0)
x86_64:easyrpg-player-0.6.1nb2.tgz(NetBSD 9.0)
x86_64:easyrpg-player-0.6.2.1nb1.tgz(NetBSD 9.0)
x86_64:easyrpg-player-0.6.2.1nb2.tgz(NetBSD 9.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]