graphics/py-pygraphviz - The NetBSD Packages Collection

Python interface to the Graphviz package

PyGraphviz is a Python interface to the Graphviz graph layout
and visualization package. With PyGraphviz you can create,
edit, read, write, and draw graphs using Python to access the
Graphviz graph data structure and layout algorithms. PyGraphviz
is independent from NetworkX but provides a similar programming
interface.

Build dependencies

pkgtools/cwrappers devel/pkgconf

Runtime dependencies

devel/py-setuptools graphics/graphviz lang/python38 lang/python38 graphics/graphviz

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfpy36-pygraphviz-1.6.tgz
NetBSD 8.0earmv7hfpy37-pygraphviz-1.6.tgz
NetBSD 8.0earmv7hfpy38-pygraphviz-1.6.tgz
NetBSD 8.0earmv7hfpy39-pygraphviz-1.6.tgz
NetBSD 8.0earmv7hfpy37-pygraphviz-1.5nb1.tgz
NetBSD 8.0earmv7hfpy37-pygraphviz-1.7.tgz
NetBSD 8.0earmv7hfpy38-pygraphviz-1.7.tgz
NetBSD 8.0earmv7hfpy39-pygraphviz-1.7.tgz
NetBSD 8.0i386py27-pygraphviz-1.5nb1.tgz
NetBSD 8.0i386py36-pygraphviz-1.5nb1.tgz
NetBSD 8.0i386py37-pygraphviz-1.5nb1.tgz
NetBSD 8.0i386py38-pygraphviz-1.5nb1.tgz
NetBSD 8.0i386py36-pygraphviz-1.6.tgz
NetBSD 8.0i386py37-pygraphviz-1.6.tgz
NetBSD 8.0i386py38-pygraphviz-1.6.tgz
NetBSD 8.0i386py39-pygraphviz-1.6.tgz
NetBSD 8.0i386py37-pygraphviz-1.7.tgz
NetBSD 8.0i386py38-pygraphviz-1.7.tgz
NetBSD 8.0i386py39-pygraphviz-1.7.tgz
NetBSD 8.0x86_64py27-pygraphviz-1.5nb1.tgz
NetBSD 8.0x86_64py36-pygraphviz-1.5nb1.tgz
NetBSD 8.0x86_64py37-pygraphviz-1.5nb1.tgz
NetBSD 8.0x86_64py38-pygraphviz-1.5nb1.tgz
NetBSD 8.0x86_64py36-pygraphviz-1.6.tgz
NetBSD 8.0x86_64py37-pygraphviz-1.6.tgz
NetBSD 8.0x86_64py38-pygraphviz-1.6.tgz
NetBSD 8.0x86_64py39-pygraphviz-1.6.tgz
NetBSD 9.0aarch64py37-pygraphviz-1.7.tgz
NetBSD 9.0aarch64py38-pygraphviz-1.7.tgz
NetBSD 9.0aarch64py39-pygraphviz-1.7.tgz
NetBSD 9.0aarch64py27-pygraphviz-1.5nb1.tgz
NetBSD 9.0aarch64py36-pygraphviz-1.5nb1.tgz
NetBSD 9.0aarch64py37-pygraphviz-1.5nb1.tgz
NetBSD 9.0aarch64py38-pygraphviz-1.5nb1.tgz
NetBSD 9.0aarch64py36-pygraphviz-1.6.tgz
NetBSD 9.0aarch64py37-pygraphviz-1.6.tgz
NetBSD 9.0aarch64py38-pygraphviz-1.6.tgz
NetBSD 9.0aarch64py39-pygraphviz-1.6.tgz
NetBSD 9.0alphapy27-pygraphviz-1.5nb1.tgz
NetBSD 9.0alphapy36-pygraphviz-1.5nb1.tgz
NetBSD 9.0alphapy37-pygraphviz-1.5nb1.tgz
NetBSD 9.0alphapy38-pygraphviz-1.5nb1.tgz
NetBSD 9.0alphapy36-pygraphviz-1.6.tgz
NetBSD 9.0alphapy37-pygraphviz-1.6.tgz
NetBSD 9.0alphapy38-pygraphviz-1.6.tgz
NetBSD 9.0alphapy39-pygraphviz-1.6.tgz
NetBSD 9.0earmv6hfpy37-pygraphviz-1.7.tgz
NetBSD 9.0earmv6hfpy38-pygraphviz-1.7.tgz
NetBSD 9.0earmv6hfpy39-pygraphviz-1.7.tgz
NetBSD 9.0earmv6hfpy27-pygraphviz-1.5nb1.tgz
NetBSD 9.0earmv6hfpy36-pygraphviz-1.5nb1.tgz
NetBSD 9.0earmv6hfpy37-pygraphviz-1.5nb1.tgz
NetBSD 9.0earmv6hfpy38-pygraphviz-1.5nb1.tgz
NetBSD 9.0earmv6hfpy36-pygraphviz-1.6.tgz
NetBSD 9.0earmv6hfpy37-pygraphviz-1.6.tgz
NetBSD 9.0earmv6hfpy38-pygraphviz-1.6.tgz
NetBSD 9.0earmv6hfpy39-pygraphviz-1.6.tgz
NetBSD 9.0earmv6hfpy36-pygraphviz-1.6.tgz
NetBSD 9.0earmv6hfpy37-pygraphviz-1.6.tgz
NetBSD 9.0earmv6hfpy38-pygraphviz-1.6.tgz
NetBSD 9.0earmv6hfpy39-pygraphviz-1.6.tgz
NetBSD 9.0earmv7hfpy37-pygraphviz-1.7.tgz
NetBSD 9.0earmv7hfpy38-pygraphviz-1.7.tgz
NetBSD 9.0earmv7hfpy39-pygraphviz-1.7.tgz
NetBSD 9.0earmv7hfpy27-pygraphviz-1.5nb1.tgz
NetBSD 9.0earmv7hfpy36-pygraphviz-1.5nb1.tgz
NetBSD 9.0earmv7hfpy37-pygraphviz-1.5nb1.tgz
NetBSD 9.0earmv7hfpy38-pygraphviz-1.5nb1.tgz
NetBSD 9.0earmv7hfpy36-pygraphviz-1.6.tgz
NetBSD 9.0earmv7hfpy37-pygraphviz-1.6.tgz
NetBSD 9.0earmv7hfpy38-pygraphviz-1.6.tgz
NetBSD 9.0earmv7hfpy39-pygraphviz-1.6.tgz
NetBSD 9.0earmv7hfpy36-pygraphviz-1.6.tgz
NetBSD 9.0earmv7hfpy37-pygraphviz-1.6.tgz
NetBSD 9.0earmv7hfpy38-pygraphviz-1.6.tgz
NetBSD 9.0earmv7hfpy39-pygraphviz-1.6.tgz
NetBSD 9.0i386py27-pygraphviz-1.5nb1.tgz
NetBSD 9.0i386py36-pygraphviz-1.5nb1.tgz
NetBSD 9.0i386py37-pygraphviz-1.5nb1.tgz
NetBSD 9.0i386py38-pygraphviz-1.5nb1.tgz
NetBSD 9.0i386py36-pygraphviz-1.6.tgz
NetBSD 9.0i386py37-pygraphviz-1.6.tgz
NetBSD 9.0i386py38-pygraphviz-1.6.tgz
NetBSD 9.0i386py39-pygraphviz-1.6.tgz
NetBSD 9.0i386py37-pygraphviz-1.7.tgz
NetBSD 9.0i386py38-pygraphviz-1.7.tgz
NetBSD 9.0i386py39-pygraphviz-1.7.tgz
NetBSD 9.0mips64ebpy36-pygraphviz-1.6.tgz
NetBSD 9.0mips64ebpy37-pygraphviz-1.6.tgz
NetBSD 9.0mips64ebpy38-pygraphviz-1.6.tgz
NetBSD 9.0mips64ebpy39-pygraphviz-1.6.tgz
NetBSD 9.0sparc64py27-pygraphviz-1.5nb1.tgz
NetBSD 9.0sparc64py36-pygraphviz-1.5nb1.tgz
NetBSD 9.0sparc64py37-pygraphviz-1.5nb1.tgz
NetBSD 9.0sparc64py38-pygraphviz-1.5nb1.tgz
NetBSD 9.0sparc64py36-pygraphviz-1.6.tgz
NetBSD 9.0sparc64py37-pygraphviz-1.6.tgz
NetBSD 9.0sparc64py38-pygraphviz-1.6.tgz
NetBSD 9.0sparc64py39-pygraphviz-1.6.tgz
NetBSD 9.0x86_64py36-pygraphviz-1.6.tgz
NetBSD 9.0x86_64py37-pygraphviz-1.6.tgz
NetBSD 9.0x86_64py38-pygraphviz-1.6.tgz
NetBSD 9.0x86_64py39-pygraphviz-1.6.tgz
NetBSD 9.0x86_64py36-pygraphviz-1.6.tgz
NetBSD 9.0x86_64py37-pygraphviz-1.6.tgz
NetBSD 9.0x86_64py38-pygraphviz-1.6.tgz
NetBSD 9.0x86_64py39-pygraphviz-1.6.tgz
NetBSD 9.0x86_64py37-pygraphviz-1.7.tgz
NetBSD 9.0x86_64py38-pygraphviz-1.7.tgz
NetBSD 9.0x86_64py39-pygraphviz-1.7.tgz
NetBSD 9.0x86_64py36-pygraphviz-1.6.tgz
NetBSD 9.0x86_64py37-pygraphviz-1.6.tgz
NetBSD 9.0x86_64py38-pygraphviz-1.6.tgz
NetBSD 9.0x86_64py39-pygraphviz-1.6.tgz
NetBSD 9.0x86_64py27-pygraphviz-1.5nb1.tgz
NetBSD 9.0x86_64py36-pygraphviz-1.5nb1.tgz
NetBSD 9.0x86_64py37-pygraphviz-1.5nb1.tgz
NetBSD 9.0x86_64py38-pygraphviz-1.5nb1.tgz
NetBSD 9.0x86_64py37-pygraphviz-1.7.tgz
NetBSD 9.0x86_64py38-pygraphviz-1.7.tgz
NetBSD 9.0x86_64py39-pygraphviz-1.7.tgz
NetBSD 9.0x86_64py37-pygraphviz-1.7.tgz
NetBSD 9.0x86_64py38-pygraphviz-1.7.tgz
NetBSD 9.0x86_64py39-pygraphviz-1.7.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.