print/hplip - The NetBSD Packages Collection

HP Linux Imaging and Printing

HPLIP (Hewlett-Packard Linux Imaging & Printing) is an HP-developed
solution for printing, scanning, and faxing with HP inkjet and laser
based printers in Linux.

The HPLIP project provides printing support for 1,980 printer models,
including Deskjet, Officejet, Photosmart, PSC (Print Scan Copy),
Business Inkjet, LaserJet, Edgeline MFP, and LaserJet MFP.  See [1]
for more information on supported printers.

[1] http://hplipopensource.com/hplip-web/supported_devices/index.html

Build dependencies

pkgtools/x11-links sysutils/dbus-python-common pkgtools/cwrappers devel/glib2-tools devel/libtool-base devel/automake devel/autoconf devel/gmake devel/pkgconf

Runtime dependencies

net/wget print/py-reportlab lang/perl5 sysutils/dbus sysutils/py-dbus graphics/jpeg net/net-snmp print/cups-base print/ghostscript devel/libusb1 sysutils/py-dbus graphics/jpeg net/net-snmp print/cups-base print/ghostscript

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfhplip-3.19.12nb9.tgz
NetBSD 8.0earmv7hfhplip-3.19.12nb9.tgz
NetBSD 8.0i386hplip-3.19.12nb9.tgz
NetBSD 8.0powerpchplip-3.19.12nb7.tgz
NetBSD 8.0powerpchplip-3.19.12nb9.tgz
NetBSD 8.0powerpchplip-3.19.12nb9.tgz
NetBSD 8.0x86_64hplip-3.19.12nb9.tgz
NetBSD 8.0x86_64hplip-3.19.12nb7.tgz
NetBSD 8.0x86_64hplip-3.19.12nb9.tgz
NetBSD 9.0aarch64hplip-3.19.12nb9.tgz
NetBSD 9.0aarch64hplip-3.19.12nb7.tgz
NetBSD 9.0aarch64hplip-3.19.12nb9.tgz
NetBSD 9.0alphahplip-3.19.12nb9.tgz
NetBSD 9.0alphahplip-3.19.12nb7.tgz
NetBSD 9.0alphahplip-3.19.12nb9.tgz
NetBSD 9.0earmv6hfhplip-3.19.12nb9.tgz
NetBSD 9.0earmv6hfhplip-3.19.12nb7.tgz
NetBSD 9.0earmv6hfhplip-3.19.12nb9.tgz
NetBSD 9.0earmv6hfhplip-3.19.12nb9.tgz
NetBSD 9.0earmv7hfhplip-3.19.12nb9.tgz
NetBSD 9.0earmv7hfhplip-3.19.12nb7.tgz
NetBSD 9.0earmv7hfhplip-3.19.12nb9.tgz
NetBSD 9.0earmv7hfhplip-3.19.12nb9.tgz
NetBSD 9.0earmv7hfhplip-3.19.12nb9.tgz
NetBSD 9.0i386hplip-3.19.12nb9.tgz
NetBSD 9.0mips64ebhplip-3.19.12nb7.tgz
NetBSD 9.0mips64ebhplip-3.19.12nb9.tgz
NetBSD 9.0powerpchplip-3.19.12nb9.tgz
NetBSD 9.0powerpchplip-3.19.12nb7.tgz
NetBSD 9.0powerpchplip-3.19.12nb9.tgz
NetBSD 9.0sparc64hplip-3.19.12nb9.tgz
NetBSD 9.0sparc64hplip-3.19.12nb7.tgz
NetBSD 9.0sparc64hplip-3.19.12nb9.tgz
NetBSD 9.0x86_64hplip-3.19.12nb7.tgz
NetBSD 9.0x86_64hplip-3.19.12nb9.tgz
NetBSD 9.0x86_64hplip-3.19.12nb9.tgz
NetBSD 9.0x86_64hplip-3.19.12nb9.tgz
NetBSD 9.0x86_64hplip-3.19.12nb7.tgz
NetBSD 9.0x86_64hplip-3.19.12nb9.tgz
NetBSD 9.0x86_64hplip-3.19.12nb9.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

fax
Enable fax support
qt5
Enable support for QT5.
sane
Enable support for SANE scanners.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.