meta-pkgs/bulk-medium - The NetBSD Packages Collection

Meta-package for a standard medium-sized limited bulk build

This package contains a medium number of packages selected to be
maximally useful for bulk building. It is intended to take about
eight hours to build on a reasonably modern machine.

Build dependencies

audio/cdparanoia audio/flac audio/flac123 audio/lame audio/mpg123 audio/sox audio/vorbis-tools chat/jabberd2 chat/sirc chat/hexchat converters/fribidi databases/mysql56-client databases/mysql57-client databases/openldap-client devel/git devel/git-base devel/git-docs devel/mercurial editors/emacs25 editors/emacs-packages editors/nvi editors/vim-gtk3 editors/xemacs-packages emulators/qemu emulators/simh emulators/tme emulators/wine graphics/ImageMagick graphics/gnuplot graphics/netpbm graphics/py-matplotlib lang/gawk lang/php73 lang/php74 lang/ruby26-base lang/ruby27-base lang/ruby30-base lang/openjdk8 lang/openjdk11 lang/python37 lang/tcl mail/fetchmail mail/imap-uw mail/mailman mail/mhonarc mail/mutt mail/alpine mail/spamassassin net/bind911 net/bind916 net/clive net/nmap net/samba4 net/wpa_supplicant net/xymon net/xymonclient net/youtube-dl pkgtools/lintpkgsrc pkgtools/pkglint print/ghostscript-agpl print/poppler-utils print/xpdf security/gnupg security/gnupg2 sysutils/desktop-file-utils sysutils/xe-guest-utilities sysutils/xenkernel413 sysutils/xentools413 textproc/ispell www/seamonkey x11/xlockmore archivers/pigz devel/cmake devel/imake devel/nasm devel/yasm graphics/icon-naming-utils audio/SDL2_mixer audio/opusfile audio/libvorbis databases/gdbm databases/p5-BDB databases/p5-BerkeleyDB databases/p5-DBD-mysql databases/p5-DBD-postgresql databases/p5-DBI databases/py-bsddb3 databases/py-gdbm databases/py-postgresql databases/py-psycopg2 databases/py-sqlite3 devel/SDL2 devel/atk devel/boehm-gc devel/glib2 devel/libelf devel/libf2c devel/libidn2 devel/libltdl devel/libusb1 devel/ncurses devel/ncursesw devel/pango devel/pcre devel/popt filesystems/fuse filesystems/perfuse graphics/SDL2_image graphics/cairo graphics/gdk-pixbuf2 graphics/glew graphics/openjpeg graphics/lcms graphics/lcms2 graphics/librsvg math/blas math/lapack meta-pkgs/boost multimedia/ffmpeg4 multimedia/libogg net/libpcap net/libsoup print/poppler print/poppler-includes security/cyrus-sasl security/openssl security/tcp_wrappers sysutils/libnotify x11/gtk3 x11/motif x11/tk meta-pkgs/suse131 audio/eawpatches audio/mpg123-pulse audio/pulseaudio databases/shared-mime-info graphics/hicolor-icon-theme devel/lua-stdlib meta-pkgs/bulk-small lang/python38 lang/python38 pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
(none)

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.